Ethernet and wireless ok, no internet

Discussion in 'Mac OS X Server, Xserve, and Networking' started by JonnyFrond, May 1, 2011.

  1. macrumors newbie

    Joined:
    Jan 15, 2011
    #1
    Hi guys,

    Can't figure this one out.

    I have two macbook pro's, one is a 2009 13" macbook pro running leopard, the other a brand new i7 15" macbook pro running snow leopard.

    I have them both configured as much the same as you can with the two operating systems and I swap them about a lot at the moment, when studying, I use the new one to work on, and the old one for internet and information. Kind of a geeky mission control thing going on.

    But now the 13" won't connect to the internet.
    Ethernet seems fine
    Wireless connection seems fine
    yet no internet.

    This happened 2 days ago, and I managed to fix it by repairing permissions and restarting. Now this has happened again today but the same thing won't fix it.

    Any pointers would be really helpful.

    Kind regards

    Jonny
     
  2. macrumors regular

    Joined:
    Jan 12, 2009
    Location:
    London
  3. thread starter macrumors newbie

    Joined:
    Jan 15, 2011
  4. thread starter macrumors newbie

    Joined:
    Jan 15, 2011
    #4
    Does no one know about this at all really?

    It seems to be a problem with dhcp. I noticed that it had a 169 IP adress, so tried to change it, now it won't get ip address automatically.

    There must be someone out there that has had this problem before, I like to think i'm unique, but that's just an ego thing really.
     
  5. thread starter macrumors newbie

    Joined:
    Jan 15, 2011
    #5
    Ok, I have found the answer to this one now, so here it is as no one seems to know it for Leopard.

    First disable firewall or allow all incoming connections.

    Network pane - advanced - TCP/IP
    change DHCP to bootp and apply it all.
    Connection will be lost. go back in, change it back to DHCP (no IP address will be assigned at this point. Apply.

    Voila

    Don't forget to put your firewall back to what it was.

    I hope this will be useful for someone.

    regards

    Jonny
     

Share This Page