Ethernet Connection between Mac and PC

Discussion in 'macOS' started by kretzy, May 15, 2006.

  1. kretzy macrumors 604

    kretzy

    Joined:
    Sep 11, 2004
    Location:
    Canberra, Australia
    #1
    I need some advice hooking up a PC laptop to my PB to do a back up of the PC's documents. I've managed to set a wireless connection between the two, but it's going to take about 6+hours to transfer all the files. I've been trying to do it more directly with an ethernet cable - just PC to PC without anything in between, but I just can't get them to connect.

    I'm a real n00b at anything to do with networking so any help will be appreciated! Thanks. :)
     
  2. sreedy macrumors 6502a

    Joined:
    Feb 24, 2005
    Location:
    Somerset
    #2
    I assume you are using standard cat5 ethernet cable, if that's the case I don't think you'll get that working without a hub... but I might be wrong.

    What you need is a cat5 crossover cable (aka "twist") for Machine to Machine connection.... that's how I do it, you can get them from all the usual places you'd get cable and they are only a few £/$
     
  3. jsw Moderator emeritus

    jsw

    Joined:
    Mar 16, 2004
    Location:
    Andover, MA
    #3
    I've had too little sleep to be sure of my advice, but I think you can simply plug the two together, assign at least one of them a self-assigned (manual) IP address, then, on the other, connect to that address. If they're both set to use DHCP, they'll get confused.

    Edit: no need for a crossover cable - that I'm sure of. Macs, at least, can handle either type of cable for connections.

    Edit 2: Is this of any help?
     
  4. kretzy thread starter macrumors 604

    kretzy

    Joined:
    Sep 11, 2004
    Location:
    Canberra, Australia
    #4
    Well that's what I thought, but apparently some computers have the ability to do it without a crossover cable, my model PB being one of them according to the Apple website.
     
  5. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #5
    Check whether the connection is up first. On the PC, it will tell you in the System Tray when the connection first goes live, and will come up with the speed and duplex settings for the interface. On the Mac, you either go to the Network applet in System Prefs, where the Network Status screen will show an orange or green blob (as opposed to red), or if you open the terminal, you can run the "ifconfig en0" command.

    The most likely reason I think for them not connecting is that the auto-assigned IP addresses aren't working correctly on one of the two machines. An easy way of getting around this is to go into the Sharing applet in System Prefs on the Mac, and share your wireless connection out via your Ethernet connection. This will assign a local IP address to the Ethernet interface, but will also allow it to assign an IP address automatically to the PC.

    Check the addresses match by comparing what's in the Sys Prefs>Network>Ethernet>TCP/IP settings on the Mac against the results of an "ipconfig" command on the PC. The two numbers should start 192.168, should have their third number the same, and only the last number will be different.

    Then, as it sounds like you already have Windows sharing enabled on the Mac, it's just a case of connecting from one to the other. From the Windows machine, you would go Start>Run... then type in \\Macname\~username, but entering your details instead (the Sharing panel will tell you the exact path if you select Windows Sharing). From the Mac, open Connect to Server from the Go menu, and type smb://windowsname/sharename

    And that should be it. After that it's just drag and drop.
     
  6. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #6
    You're right. Virtually every G4 and every G5 based Macs will auto-crossover, so a straight through Ethernet cable will still work.
     
  7. sreedy macrumors 6502a

    Joined:
    Feb 24, 2005
    Location:
    Somerset
    #7
    Cool didn't know that, I always use a crossover.... but I guess thats because I have one handy!
     
  8. kretzy thread starter macrumors 604

    kretzy

    Joined:
    Sep 11, 2004
    Location:
    Canberra, Australia
    #8
    Thanks for the advice so far guys! I think I'm getting somewhere but still unable to get them too connect. I checked both of the IP addresses and they're same on both the Mac and the PC. Does that mean I have to change the IP on the Mac?
    The ethernet status looks like this if that helps at all.

    On the PC, the LAN status is "Limited or no connectivity"

    Also when I try entering the name of my Mac on the PC I just get an error message saying "The network path was not found"
     

    Attached Files:

  9. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #9
    You have an orange blob, so there is an active physical connection. The problem must be with the addressing.

    Try manually configuring the IP addresses (note: this isn't a permanent solution, but will work)

    On the Mac, go into System Prefs>Network>Built-in Ethernet>TCP/IP and enter the following:-

    IP address 192.168.1.1
    Subnet mask 255.255.255.0
    Router 192.168.1.1

    On the PC, go into Start>Settings>Network Connections. Right click on Local Area Connection and select properties. Highlight Internet Protocol (TCP/IP) in the list and click on the button marked Properties. Set as the following

    IP address 192.168.1.2 <- Note the 2 here.
    Subnet mask 255.255.255.0
    Default gateway 192.168.1.1

    OK all the boxes.

    Now from the Mac, select Connect to Server from the Go menu, and type

    smb://192.168.1.2

    You should be prompted for a password. Transfer the files, then set everything back to automatic addressing on both machines so it doesn't cause problems later.
     
  10. kretzy thread starter macrumors 604

    kretzy

    Joined:
    Sep 11, 2004
    Location:
    Canberra, Australia
    #10
    Thank you so much dynamicv and everyone that helped! You're last suggestion worked perfectly.

    Thanks again!!! :)
     
  11. Queso macrumors G4

    Joined:
    Mar 4, 2006

Share This Page