Ethernet Connection suddenly stopped working

Discussion in 'MacBook Pro' started by zwilliams88, Jan 20, 2007.

  1. zwilliams88 macrumors newbie

    Joined:
    Jan 20, 2007
    #1
    I connect my Macbook to a LAN through an ethernet connection. Has worked fine for months. Then today without changing any settings or anything just suddenly stopped working. All the other computers on the network still connect fine. Ive even tried swapping out the ethernet cables but it still wont work. In the network settings panel it has the red disconnected button next to built in ethernet, and says "Ethernet cable is not connected". I'm assuming now that the ethernet card itself is messed up, which is dissapointing since i just purchased this computer in august. any help would be appreciated.
     
  2. MacNut macrumors Core

    MacNut

    Joined:
    Jan 4, 2002
    Location:
    CT
    #2
    Just reset it. It should say configure ethernet.
     
  3. zwilliams88 thread starter macrumors newbie

    Joined:
    Jan 20, 2007
    #3
    I've tried reseting and reseting the modem. No luck. Is it possible that the ethernet card would stop working after only a couple months?
     
  4. aaronw1986 macrumors 68030

    Joined:
    Oct 31, 2006
    #4
    Possible, but unlikely. Did you check the router? Maybe the cable is loose there, or the port isn't working.
     
  5. zwilliams88 thread starter macrumors newbie

    Joined:
    Jan 20, 2007
    #5
    I've checked all cables. Reset the modem and router. Im convinced that the ethernet card is messed up. I didnt get the extra support care. Is there some kind of limited warranty that would replace this? I got the macbook in August.
     
  6. aaronw1986 macrumors 68030

    Joined:
    Oct 31, 2006
    #6
    You are covered for a year, so you are fine. Give apple a ring.
     

Share This Page