Ethernet Link Keeps Going On and Off

Discussion in 'MacBook Pro' started by Fahd, Jan 10, 2007.

  1. Fahd macrumors regular

    Joined:
    Oct 26, 2003
    #1
    I have an issue with a MacBook running Mac OS X where the network link comes on for a few minutes and then goes off and keeps coming on and off.

    Sometimes, the link stays active for a few hours and then it goes off again.

    Any tips on troubleshooting? Could this be a hardware problem?

    I ran the hardware test off the Mac OS X Tiger CD and everything came back fine, but I think that hardware test only tests the main logic board and memory and not the NIC.

    Appreciate any help or suggestions!

    Thanks!
     
  2. superbovine macrumors 68030

    superbovine

    Joined:
    Nov 7, 2003
    #3
    check the cable, including sources of interference. (swap the cable with a different one)
    trying changing port on the switch
     
  3. Fahd thread starter macrumors regular

    Joined:
    Oct 26, 2003
    #4
    Its definitely not the port or cable; its definitely something on the macbook. I am guessing hardware problem.

    I haven't tried resetting the SMC yet but I did upgrade the SMC firmware and still no luck!
     
  4. Paul Wright macrumors regular

    Paul Wright

    Joined:
    Aug 24, 2006
    Location:
    Germany
    #5
    yeah, check again, i had a cable it worked perfectly wih my PC but i could slide the cable out of my macbook meh and i never realised it until i did it with my hand by accident. Changed the RJ45 connector and w00t it works :p
     

Share This Page