Excel tries to open e-v-e-r-y-t-h-i-ng!

Discussion in 'Mac Basics and Help' started by crazyhorse634, Sep 16, 2005.

  1. crazyhorse634 macrumors newbie

    Joined:
    Aug 18, 2005
    #1
    Hi, Mac users,- got a question, as usual. ;-)

    How do I change my default opener for downloads from Excel? I don't even know how it became the default opener for downloads!

    Meg
     
  2. yenko macrumors 6502a

    Joined:
    Aug 29, 2005
    Location:
    SouthWest-USA
    #2
    Repair permissions!

    Restart! :)
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    Hopefully a permissions repairing session will solve your problems. However, if not, select the download, type APPLE-I (for Get Info) and you can select which app opens each download. You may then press the Apply for all button.

    By the way, you have to make sure that it has the correct file suffix. If it is a disk image, ensure it says .DMG at the end. :)
     
  4. stevep macrumors 6502a

    stevep

    Joined:
    Oct 13, 2004
    Location:
    UK
    #4
    I have the same problem. If I save a file to the desktop (eg a pdf file) the next time I open Excel it will open the pdf file (badly I might add, just garbled text and images). It will do the same with text and image files, or attempt to. Trashing the files has no effect. Repairing permissions has no effect. (In fact I find repairing permissions in general to be a fairly useless pastime when it comes to sorting out problems, and yet everyone seems to recommend it).
    Even trashing the files it attempts to open, and emptying the trash, has no effect - Excel still seems to dig them up from somewhere.
    So I sympathise with your problem CrazyHorse, but as yet haven't found an answer.
     
  5. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #5
    Some people in another thread suggested this could happen if you use Internet Explorer. If that's the case, try Safari or Firefox and see if it helps.
     
  6. stevep macrumors 6502a

    stevep

    Joined:
    Oct 13, 2004
    Location:
    UK
    #6
    Try getting rid of the files Excel is opening, then open Excel, go to Preferences, General and change the locations that Excel uses to open files from, and saves files to. For instance, change them both to the Desktop if they were previously Documents.
    I've just done this on my machine and it seems to work (for the moment anyway).
     
  7. neocell macrumors 65816

    neocell

    Joined:
    May 23, 2005
    Location:
    Great White North
    #7
    How about deleting Excel's Preferences by deleting the plist file

    User > Library > Preferences > com.microsoft.Excel.plist
     
  8. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #8

    Very true, but since it gets recommended and therefore done so often, maybe it actually does help... Who knows...

    Anyway, is it across all accounts on the Mac? I'm guessing it probably isn't. Deleting a file called com.apple.finder.plist may help, but no guarantees.
     
  9. FFTT macrumors 68030

    FFTT

    Joined:
    Apr 17, 2004
    Location:
    A Stoned Throw From Ground Zero
    #9
    It sounds like you inadvertently set Excel as the default application to your "open with" all files in your Home/Documents folder or the file you were working on.

    When you try to open a previously unknown or undesignated file, you get the popup window
    asking you to specify the application needed to open the file. You can then either chose to open just that
    file or set it as default for all similar files.

    That's what I think you did.

    Go to your Home folder and try to open another file type like a photo.

    Control click or right click on the selected file and
    you'll see "open with " in the menu.

    You'll see the default opening application at the top.

    Then select PhotoShop, Preview or Graphics Converter depending on your preference.

    Then do the same with a text document from your documents file "open with" Word, Appleworks or Text Edit or Pages.

    I hope this helps.

    I know it hard to follow without seeing the images .

    Trashing the Excel plist in Home/Library/Preferences should reset Excel until you use it again.
     
  10. stevep macrumors 6502a

    stevep

    Joined:
    Oct 13, 2004
    Location:
    UK
    #10
    This isn't what the problem is. If I double-click a jpg on the desktop it opens with (in my case) Photoshop - exactly what I want to happen. Similarly, dbl-clicking a pdf will open Acrobat, as you'd expect. But going to Applications and opening Excel will result in a host of files being opened - in my case files that had previously been saved to the desktop.
    I've tried trashing the plist files referred to above but it doesn't work. What has worked is as in my last post above. I think its a bug in Excel, and will probably be one of those annoying little things that will re-occur from time to time.
     
  11. FFTT macrumors 68030

    FFTT

    Joined:
    Apr 17, 2004
    Location:
    A Stoned Throw From Ground Zero
    #11
    I'm glad you figured it out.

    So it's a Microsoft thing, Go figure.
     
  12. stevep macrumors 6502a

    stevep

    Joined:
    Oct 13, 2004
    Location:
    UK
    #12
    Absolutely, and I nearly made a comment similar to yours at the end of my post!!! In fairness however, MS Office does do most things more or less ok, and its very nice to be able to transfer docs and spreadsheets across platforms with usually no problems.
    Thanks for your suggestions.
     

Share This Page