Exposé Slowing Down/Choppy

Discussion in 'MacBook Pro' started by reda, Nov 23, 2006.

  1. reda macrumors newbie

    Joined:
    Nov 23, 2006
    #1
    Hi guys,

    I am having this problem:

    My expose runs choppy (a bit) when my machine runs on battery power (even fully charged and in best performance mode). It runs really smoothly though when it's plugged to a power supply.

    I am not running any mem hogging program at the time....

    Does anyone has the same problem with their Core 2 Duo Macbook Pro (mine's the 2.33Ghz , 2 GIG RAM model...)
     
  2. Jiddick ExRex macrumors 65816

    Jiddick ExRex

    Joined:
    May 14, 2006
    Location:
    Roskilde, DK
    #2
    I don't own a mbpc2d but I have seen quite some posts about it. All followed by "stop whining" which is annoying since it seems like a real issue.
     
  3. reda thread starter macrumors newbie

    Joined:
    Nov 23, 2006
    #3
    Thaks for the replay.
    Actually I just wanna know if the "problem" affets all the C2D MBPs or only some.
    I'll try in a C2D MBP thread...
     
  4. MacBoobsPro macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #4
    Its fine on my Core Duo. Although I have heard of similar probs on C2D. Try a search at MR as I know i have seen something about it.
     
  5. jymloke macrumors newbie

    Joined:
    Nov 23, 2006
    #5
    I am having the same problem on my MBP C2D. I am not whining but the slowdown is really annoying and I expct full bang for my buck....

    May I know what MR is?????? Is there a solution to this???
     
  6. gekko513 macrumors 603

    gekko513

    Joined:
    Oct 16, 2003
    #6
    My MacBook Pro is also a bit slow to speed up whenever it runs on battery power and has to do some graphics stuff like Exposé. I'm sure it is related to energy saving, but I agree it's quite annoying that you can't turn it off.

    MR means macrumors.
     
  7. uv23 macrumors 6502

    Joined:
    Nov 16, 2003
    Location:
    Calgary, AB
  8. tejota1911 macrumors 6502

    Joined:
    Nov 10, 2006
    #8
    My MBP C2D is not effected by this either. There is no noticeable slowdown when running on battery power.
     
  9. reda thread starter macrumors newbie

    Joined:
    Nov 23, 2006
    #9
    Could you please check again :

    - Open a dozen windows
    - Unplug the power cord
    - Wait 5min
    - Do a windows rearrengement with exposé

    Is it exactly as smooth as when using the power cord?

    Thanks in advance!
     
  10. heehee macrumors 68020

    heehee

    Joined:
    Jul 31, 2006
    Location:
    Same country as Santa Claus
  11. reda thread starter macrumors newbie

    Joined:
    Nov 23, 2006
  12. uv23 macrumors 6502

    Joined:
    Nov 16, 2003
    Location:
    Calgary, AB
    #12
    Yep, smooth. Perhaps very slightly slower, but not choppy at all.
     
  13. e12a macrumors 68000

    e12a

    Joined:
    Oct 28, 2006
    #13
    I'm not sure, but does OSX use GPU and CPU throttling to save energy? On battery make sure you're in "Better Performance" mode. :) It automatically reverts to "Better Battery Life" when on battery. Check that out.

    edit: ah i see that you've selected the mode. Well, it can also depend if you're running any Rosetta apps. i've noticed it slows down expose.
     
  14. reda thread starter macrumors newbie

    Joined:
    Nov 23, 2006
    #14
    Yep it's slower, a bit laggy... Do you confirm this ?



    No i'm not running Rosetta
     
  15. ero87 macrumors 65816

    ero87

    Joined:
    Jan 17, 2006
    Location:
    New York City
  16. Eraserhead macrumors G4

    Eraserhead

    Joined:
    Nov 3, 2005
    Location:
    UK
    #16
    MR=MacRumors.com
     
  17. uv23 macrumors 6502

    Joined:
    Nov 16, 2003
    Location:
    Calgary, AB
    #17
    I wouldn't say it was laggy. Just not as spry. :) Most likely to due to energy saving.
     
  18. reda thread starter macrumors newbie

    Joined:
    Nov 23, 2006
    #18
    I think we mean the same thing :)
     
  19. kerisimasi macrumors member

    Joined:
    Jul 1, 2006
    #19
    Slow Expose On Battery

    Hey Reda - Same exact problemo here - have been postin about it on MR for a few weeks now...I was actually planning on going to an Apple store this weekend to get it looked at. It gets worse with more windows open...however immediately after I plug it in, PERFECTLY smooth. I know people say to stop whinning, but it actually bothers the hell out of me for 1 reason - my macbook 2.0ghz never had this problem and seemed much quicker on battery power. BTW, this is a MBP C2D 2.16ghz - any suggestions?
     
  20. chosenwolf macrumors 6502a

    chosenwolf

    Joined:
    Feb 4, 2006
    Location:
    Los Angeles
    #20
    I have a thread about this issue as well from months ago. I had the issue on my CD MBP and now on my C2D MBP.

    When plugged in, Dashboard and Expose run as smooth as silk. As soon as I'm on battery power, both get choppy. I've tried numerous steps to fix the problem, but up to date no one has found a real solution. Let me know what the Apple Genius says...
     
  21. kerisimasi macrumors member

    Joined:
    Jul 1, 2006
    #21
    should i call applecare?

    have you considered talking with applecare? do you think they would give us the time of day? the c2d should be able to handle expose yeah? I am just wondering if I should even try bringning it to an apple store. if they are all like this, then I don't think they would do much about it....however if some are slow on battery power, then there is obviously something wrong.
     
  22. stevehp macrumors 6502

    Joined:
    Sep 4, 2006
    Location:
    It's not a house, it's a home.
    #22
    same problem (Far from a real problem in my opinion, though) on my machine.
     
  23. TheSpaz macrumors 604

    TheSpaz

    Joined:
    Jun 20, 2005
    #23
    It may have to do with beam sync. Check out this fix:

    found the defaults to change: use this console cmd:

    sudo defaults write /Library/Preferences/com.apple.windowserver Compositor -dict deferredUpdates 0

    You can verify this by opening /Library/Preferences/com.apple.windowserver in Property List Editor and expand "Compositor"

    Open Quartz Debug and reveal the Beamsync tools. change the setting.

    Reopen /Library/Preferences/com.apple.windowserver and expand Compositor to see the new setting.

    0 = disable beamsync

    1 = Auto beamsync

    2 = force beamsync

    Of course, YMMV.

    Enjoy!
     
  24. kerisimasi macrumors member

    Joined:
    Jul 1, 2006
    #24

    thanks spaz - but I apologize, I am quite a newbie when it comes to mac, haen't messed around with any of the console stuff....not sure what quartz debug is, etc. I'd hate for you to have to hold my hand through the previous instructions, but if you could point to the right directions i'd be set. Thanks for your help...anyone else try this fix yet?? What exactly will it do and how is related to battery power vs. AC power? Thanks
     
  25. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #25
    Is it me or did the Security Update fix the choppiness/laggyness?
     

Share This Page