Expose and Illuminated Keyboard?

Discussion in 'Mac OS X 10.3 (Panther) Discussion' started by qubex, Jun 4, 2004.

  1. qubex macrumors 6502

    qubex

    Joined:
    May 12, 2004
    Location:
    045°042'21.99"N, 009°005'056.57"E
    #1
    Hello.

    Finally I have taken delivery of my new 15" PowerBook but I have a very annoying problem.

    The default keybindings for Expose and the Illuminated Keyboard feature clash: Expose uses F9-F10-F11 while Illuminated Keyboard uses F8-F9-F10. I've tried to reassign the Expose bindings in the Expose preferences pane but this has not had any effect.

    I'm sure I'm not the only one to have encountered this problem. What have *you* done?
     
  2. stoid macrumors 601

    stoid

    Joined:
    Feb 17, 2002
    Location:
    So long, and thanks for all the fish!
    #2
    F12 - Desktop
    F11 - Current Application
    Apple-F11 - All windows

    To set one to contain an additional modifier key, just press the modifier key when selecting an F button in the Expose preference pane. Or just hold the fn key in the lowest left-most position of the keyboard to use the F-keys as F-keys and not as sound and brightness and backlight controls.
     
  3. qubex thread starter macrumors 6502

    qubex

    Joined:
    May 12, 2004
    Location:
    045°042'21.99"N, 009°005'056.57"E
    #3
    Yeah, that's what I did, but it didn't have any effect. Now I'm rebuilding my hard drive permissions just in case that's the problem.
     
  4. qubex thread starter macrumors 6502

    qubex

    Joined:
    May 12, 2004
    Location:
    045°042'21.99"N, 009°005'056.57"E
    #4
    No I can't get it to work.

    Has anybody else experienced problems reassigning Exposé keys, or is it just me?

    The selectors show the ^F9, ^F10, ^F11 (command-) or fleur-de-ils motif and relevant F-keys, but it doesn't make a difference. Every time I press F9 or F10, whatever the modifiers, I just get the gray illuminated keyboard bevel.
     
  5. cb911 macrumors 601

    cb911

    Joined:
    Mar 12, 2002
    Location:
    BrisVegas, Australia
    #5
    well it sounds like your 'fn' modifier key for F10 isnt' working?

    you might have to re-install OS X, or get your keyboard checked out to see if everything is working.
     
  6. Abstract macrumors Penryn

    Abstract

    Joined:
    Dec 27, 2002
    Location:
    Location Location Location
    #6
    If you set F11 = Expose
    F12 = Show Desktop

    and forget about the other button (show current window?), does it work out?

    I never use the other feature. Its not very useful for me.
     
  7. dabirdwell macrumors 6502

    Joined:
    Sep 26, 2002
    Location:
    Oklahoma
    #7
    Shortcuts

    I use the Function key to show desktop, it is super convenient to have it as the corner key. My left hand naturally falls there when using the trackpad with my right. It makes it effortless to slide all the windows away. I also put the "show all" command in the lower left, on the option key, for similar reasons.

    My fiance who has to use option all the time has her "all windows" set to F12, so bottom left is show desktop and top right is show windows.
     
  8. qubex thread starter macrumors 6502

    qubex

    Joined:
    May 12, 2004
    Location:
    045°042'21.99"N, 009°005'056.57"E
    #8
    I had to go into the Keyboard Preferences and select the little use-as-custom-keys option. Now Exposé is back to my F9-F10-F11 keys but in the process now I have press Fn-F3, Fn-F4, Fn-F5 to control volume etc. I guess you win some and you lose some.
     

Share This Page