external Lacie HD will not mount

Discussion in 'Mac Basics and Help' started by chasemac, Nov 6, 2006.

  1. chasemac macrumors 6502a

    chasemac

    Joined:
    Jan 30, 2005
    Location:
    In a house.
    #1
    Okay. I woke up this morning and my mac was shut down due to a power outage last night. I started up and everything was fine except one of my Lacie external drives would not mount.:mad: I have two Lacie drives connected to each other and the second one will not mount. I can see it in disc utility but when I try to repair it I get an error. I have downloaded and used the demo version of Data Rescue and it looks like it may be able to at least recover most of my files. Can anyone offer any help or suggestions on this problem before I spend the $99 Data Rescue asks to retrieve my imports files.

    Thanks,

    chasemac
     

    Attached Files:

  2. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #2
    Sorry mate, I think Data Rescue II is probably your best bet. I hope it works for you. :)
     
  3. MikeTheC Guest

    MikeTheC

    Joined:
    Apr 26, 2004
    Location:
    Gallifrey -- Capitol City, Prydonian Sector
    #3
    I'd suggest DiskWarrior. It's usually a real champ when it comes to fixing problems on storage media.
     
  4. chasemac thread starter macrumors 6502a

    chasemac

    Joined:
    Jan 30, 2005
    Location:
    In a house.
    #4
    Yes!! An A+ for DW. Bought it today from their website and it took about 2 hours to rebuild its directory. Now back running! Thank You Very Much!:D

    chasemac
     
  5. MikeTheC Guest

    MikeTheC

    Joined:
    Apr 26, 2004
    Location:
    Gallifrey -- Capitol City, Prydonian Sector
    #5
    Glad to hear it worked. Usually with DW, the data itself has to be corrupt for you not to be successful. But at that point, you're pretty well and truly screwed.
     

Share This Page