External Sound Card: Forcing 5.1? Or Getting Traktor to play and recognize 4 chans?

Discussion in 'macOS' started by BigDaddy5, Dec 19, 2006.

  1. BigDaddy5 macrumors member

    Joined:
    Dec 6, 2006
    #1
    I'm really not sure this is a OS X issue, software issue, or hardware issue...

    I'm using a Sound Blaster Extigy as an external sound card for a DJing setup. It's worked pretty well so far with a windows machine (I don't make a ton DJing, so I don't buy top end gear yet, it's more of a hobby).

    The thing I had to do in XP, though, to get it to work properly was I had to go into the control panel and get it to play as a 5.1 channel setup. Unfortionatly there's no option to do same in OS X.

    But that's not the only problem, the problem I have right now is there's no way to get any sound out of the main channels. I can only play sound through the headphone output of the sound card. It sounds pretty decent through the headphone output, but that's not a viable solution, I need to run the channels to a separate mixer.

    So that leads to my question...what am I doing wrong? Is it something I need to tinker with in OS X to get any program to play through the main outputs (this includes iTunes, quicktime, etc...they all only play in the headphones of the sound card). Is it a hardware incompatibility? OS X recognizes the Extigy, so I don't believe that's the case. Is it something I need to adjust in each individual program? I don't really think this is the case, as it's a global issue. I'm really leaning towards it being an OS X setting I'm missing somewhere, so I'd appreciate any help.

    Now, before you ask, I have unplugged the headphones! I only recently plugged them in to troubleshoot. I have also rebooted both the sound card while plugged in and the macbook pro while it was plugged in. I'm really leaning towards it being a missed setting in OS X somewhere. Like I said, the sound card didn't work properly in XP either unless I went into the control panel and adjusted it to 5.1. Any advice would be greatly appreciated.
     
  2. Savings macrumors member

    Joined:
    Dec 16, 2006
    #2
    Try tinkering with the settings in Audio MIDI setup in the Utilities folder. Mapping speakers to sound card channels is done there, so you can configure the card to playback in a quadraphonic or 5.1 configuration or whatnot. As far as getting the Traktor sound right, you may have to tinker in Traktor's audio settings for a bit to get it working right. Try switching around the channels in Audio MIDI setup and see how it affects Traktor's outputs. You may need to restart Traktor to see changes reflected.

    Anyhow, you set the 5.1 in Audio MIDI setup. Hope that helps.
     
  3. BigDaddy5 thread starter macrumors member

    Joined:
    Dec 6, 2006
    #3
    Well, I appreciate the tip, and I checked it out. Unfortionatly, for some reason, I'm limited to stereo output. I think there's something odd with the way OS X is detecting my sound card, because it seems to only want to route sound through the headphones, not the main speaker outputs. THey are all connected, so there's no excuse why it shouldn't.

    I appreciate the tip, and I hope I can get a few more!
     
  4. Savings macrumors member

    Joined:
    Dec 16, 2006
    #4
    The system is probably defaulting to playing out of channels one and two of the multichannel device. You could try switching which channel is assigned to which output, if it lets you, or try using Audio Hijack Pro to set the application's audio to route to a different output or mirror one output onto another.

    Audio Hijack is a great program to have alongside Traktor for recording Traktor's output as well, since Traktor's Native Mix recorder never really worked quite right for me. You can also apply VST and other effects to Traktor's output with Audio Hijack.

    The regular Audio Hijack probably does most of this, but Pro has so many more features that it's a must have Mac audio program for me.
     

Share This Page