1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

external WD my passport freezes 2013 MBA

Discussion in 'MacBook Air' started by PavelT, Sep 11, 2013.

  1. macrumors member

    #1
    hello, i was wondering if anyone else has this issue. i noticed that the 1TB wd my passport usb 3.0 does not work on my 2013 macbook air (tried 2TB passport and works just fine, btw)..... when i plug it in, it intermittently freezes my macbook air, also does not even recognize it. when i unplug it, everyone goes back to normal...anyone?
     
  2. #2
    Does it happen on both USB ports or/and with both USB 3.0 cables?
     
  3. macrumors 6502

    #3
    Try repairing permissions on both MBA's SSD and the WD drive, see if that helps.
     
  4. macrumors member

    #4
    yeah it happens on both usb 3 ports on the mba. i have also tried a differant usb 3 cord, just in case it was a faulty cord. so its not the cord. also, the drive works just fine on just about every computer(2012 mba, mbp, 2013 imac, etc). except the 2013 macbook air...also i have repaired permissions, but it didn't do anything.
     
  5. macrumors 68030

    flowrider

    #5
    I'm using a Seagate Hybrid (Fusion) 500GB SSHD in an Orico USB 3.0 enclosure without incident, in fact when I'm in a stationary place, that is my boot drive. I have some USB 2.0 flash stocks, and have no problem with those either. If you have eliminated the cable, there must be something wonky with the connector on your Passport. Don't know what else it could be.

    Lou
     
  6. macrumors 65816

    #6
    I also have a 1TB passport and haven't noticed any issues on my 2013 11" MBA.
     
  7. macrumors member

    #7
    oh wow. that is strange then. a 1tb my passport (the current generation, not the "for mac" one though. i had to format it once i got it, so it can work.) i have also secure erased it. and nothing. still once i plug it in, it freezes down my 2013 mba 11'' ( works just fine on a 2012 mba, but freezes a 2013 mba) and doesn't appear on my finder...
     
  8. #8
    Then it is probably a wonky USB chipset on the HDD. Can you still return it or let it be replaced by WD?
     
  9. macrumors 65816

    #9
    I think we are talking about the same model. Mine is a black My Passport 1GB. I formatted it as Journaled HFS+ when I got it and have been using it for encrypted time machine backups.

    This is how it shows in System Information:


    My Passport 0748:

    Product ID: 0x0748
    Vendor ID: 0x1058 (Western Digital Technologies, Inc.)
    Version: 10.19
    Serial Number: xxxxxxxxx
    Speed: Up to 5 Gb/sec
    Manufacturer: Western Digital
     
  10. macrumors member

    #10
    yeah, thats the one i have. this is strange......
     
  11. macrumors 6502

    #11
    "For Mac" just means it's pre-formated in HFS+ and has a "Mac like" grey or white casing with a price mark up.
     
  12. macrumors demi-god

    Weaselboy

    #12
    WD has Mac software you can use to update the firmware on their drives. You might try using that to make sure you have the newest WD firmware release.
     
  13. macrumors member

    #13
    yeah. i was very hopeful of this when i thought of it. i have done this update for mac wd firmware, to no avail. still same problem.
     
  14. macrumors 6502a

    #14
    Yep. As soon as I found that out, I obviously passed on paying the premium for no reason at all really.
     
  15. macrumors 65816

    #15
    not that strange mate...it happens:(
    try repairing permissions or even reformatting, but i have the same drive (although mine is 2tb) and it works great.

    as it were, the "my passport for mac" is WAY overpriced imo so you bought the right drive. hopefully it's still under warrranty

    good luck
     
  16. macrumors member

    #16
    yeah i also have the 2tb passport and it works just fine. i have reformatted, repaired, etc. works fine on every other computer at the apple store and friends macs. just doesn't work on the macbook air 2013.
     

Share This Page