eyetv - problem exporting HD

Discussion in 'Digital Video' started by twoodcc, Oct 2, 2006.

  1. twoodcc macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #1
    ok, so i have the eyetv hybrid, and a powered HDTV antenna. they both work great, and i see a great picture on my computer. but, after recording something, i'm having trouble exporting.*

    is seems no matter what i do, it takes forever to export anything. i have an intel iMac 17" 1.83 ghz and 1.5 GB of ram

    when i try to export in the eyetv software, it never finishes exporting. after about 12 hours, i check in activity monitor, and it's doing nothing. i've tried exporting to toast, and then use toast to make a disk image, then use handbrake to convert to mpeg-4, but it seems the quality isn't very good.*

    any ideas on how to keep it good quality?

    thanks in advance
     
  2. twoodcc thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
  3. amiga macrumors 6502

    amiga

    Joined:
    Jul 12, 2006
    Location:
    London.
  4. twoodcc thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #4
    well i can't even export HD at all. i have to send it to toast, and then export it from toast (divx)

    but was wondering if there's a better way
     
  5. amiga macrumors 6502

    amiga

    Joined:
    Jul 12, 2006
    Location:
    London.
    #5
    Have you tried sending it to Imovie? I seem to remember that it was a bit quiker for me that way. Not done it for a while though.
     
  6. twoodcc thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #6
    i'll try it.*
     
  7. twoodcc thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #7
    so can anyone tell me how they export their HD recordings?
     
  8. sandman42 macrumors 6502a

    sandman42

    Joined:
    Oct 23, 2003
    Location:
    Seattle
    #8
    I can't tell you how to solve your problem (sorry), but what I can tell you is that even regular NTSC can take a long time to export, depending on your target format. I'm working on editing some stuff I recorded in hi-res MPEG2, and when I export it to DV it takes about 1.5x real time to export, so about 3 hours to export 2 hours of video on my 1.42GHz G4 Mini. I suspect that HD is substantially more processor intensive. Can't explain why your computer shows little activity after running for a while. Have you looked at Activity Monitor earlier in the process, and does it show significantly more activity?
     
  9. twoodcc thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #9
    see that's the thing. after waiting like 12 hours, i check activity monitor and it's not doing anything. nothing.
     
  10. Super Macho Man macrumors 6502a

    Super Macho Man

    Joined:
    Jul 24, 2006
    Location:
    Hollywood, CA
    #10
    I don't know how to fix that problem, but there is a workaround. Go to your EyeTV Recordings folder, right-click on the .eyetv file of your recording and click Show Package Contents. The raw transport stream file is in there, with an .mpg extension. You can then open that up in MPEG Streamclip or ffmpegX or whatever to transcode. ffmpegX is probably faster and higher quality than the EyeTV software anyway.

    MPEG Streamclip will let you trim the recording, too, and it will do a better job than EyeTV software.
     
  11. twoodcc thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #11
    thanks, i've tried that before with one that i trimmed in eyetv, and it didn't work right. the sound didn't match the video after using MPEG Streamclip to convert it.

    i guess i have to trim with MPEG Streamclip or ffmpegX
     
  12. sandman42 macrumors 6502a

    sandman42

    Joined:
    Oct 23, 2003
    Location:
    Seattle
    #12
    I don't want to hijack your thread, but since you guys seem to have some good experience with this stuff maybe you can help me out. I'm having an EyeTV export problem of my own:

    I recorded a program with EyeTV set to high quality MPEG-2 (90 min DVD, 2.7Gb/Hr) that I want to export to iMovie/iDVD to make a DVD. The program is wide screen, but it was broadcast in letterbox 4:3. I tried exporting it from EyeTV as Widescreen DV (which successfully crops out the letterbox bars) but it comes out with really bad horizontal lines that go in and out of phase a few times a second. It's as though there's a frame rate problem, perhaps, and every few frames there's an interpolation between adjacent frames, interlacing them very coarsely.

    See the attachments.

    Any idea how to prevent this? I want to create a widescreen DVD, and it seems like I should be able to do that, but I'll make it letterboxed if I have to.

    Thanks!
     

    Attached Files:

  13. twoodcc thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #13
    there is a setting to prevent that. i forgot what it was called though. i'm not sure if you have the setting in eyetv software of not, but i know i've seen it somewhere. i'll try to figure out what it is, and maybe someone else will also help
     
  14. twoodcc thread starter macrumors P6

    twoodcc

    Joined:
    Feb 3, 2005
    Location:
    Right side of wrong
    #14
    actually it's called "deinterlace". that is supposed to solve the horizontal lines. you have to have a program that has this setting to solve it.
     
  15. sandman42 macrumors 6502a

    sandman42

    Joined:
    Oct 23, 2003
    Location:
    Seattle
    #15
    Hmmm, I've discovered that it's something the export function of EyeTV is doing -- when I take the DV file EyeTV creates and play it anything (iMovie, QT, etc), it looks like that. So for some reason EyeTV is creating the fouled up video when I export it. I can't find a setting in EyeTV that prevents it. I've tried setting the scan mode to Progressive and Interlaced, and they both do it.
     
  16. Super Macho Man macrumors 6502a

    Super Macho Man

    Joined:
    Jul 24, 2006
    Location:
    Hollywood, CA
    #16
    I think the Progressive Scan setting in EyeTV only affects displaying, not exporting. But I don't know why exporting to DV would introduce that interlacing problem. Does it happen only with the DV, or does it continue to happen even after it's converted to MPEG-2 and burned onto a DVD?

    Maybe try exporting to DV using MPEG Streamclip or ffmpegX instead.

    Another thing is that converting from HDTV MPEG-2 -> DV -> DVD MPEG-2 is going to cause quality loss. If you aren't doing anything in iMovie apart from trimming, and don't need the pretty menus, you might want to try to get rid of the DV conversion step. If you have the money to shell out for Toast, it's worth it.
     
  17. lost_mobius macrumors newbie

    Joined:
    Oct 1, 2004
    #17
    EyeTV 500 I Have Been Successful

    The way I did it was to export to mpeg program stream then convert that to something smaller, like quicktime or mpeg streamclip. It is hard sometimes it helps to check the stream info and figure out whether the stream is progressive or interlaced, so the program you use to convert the mpeg program stream can deinterlace or make a progressive movie. It definitely is not a fast process but this is the fastest I've figured out so far.
     
  18. lost_mobius macrumors newbie

    Joined:
    Oct 1, 2004
    #18
    I meant to say using either the program quicktime or mpeg streamclip. Sorry
     
  19. jimTV macrumors newbie

    Joined:
    Oct 17, 2006
    #19
    I can't answer the main question, sorry, but I can tell you that those lines you're seeing are the fields.
    If the full hight of the picture was (for example) 100 lines, and the area within the letter box was 70 lines. By blowing the image up you're stretching those 70 lines across where there should be 100. Deinterlacing will help, but you're going to get a soft picture.
     
  20. Arnaud macrumors 6502

    Joined:
    May 24, 2005
    Location:
    The Moon
    #20
    I wouldn't be so sure.
    I had previous issues with exporting some footage, and a part of it showing big fat black lines. Turned out that I had to set the aspect ratio in the View menu to 4:3-or-whatever, instead of automatic, because this would mess-up with the exported file.
    Maybe try all the options in EyeTV Preferences / Display / Deinterlace...

    If you can't find any answer here, and haven't tried the support yet, I'd advise you to send an email to elgato. They are very friendly and helpful, they helped me out a couple of times. I actually wish all Helpdesk were that nice and dedicated... :rolleyes:
     
  21. sandman42 macrumors 6502a

    sandman42

    Joined:
    Oct 23, 2003
    Location:
    Seattle
    #21
    I found a solution (to my exporting problem, at least). My original goal was to take my recorded 4:3 video, which was actually letter-boxed widescreen content (Sci-Fi's BSG), and crop it back down to 16:9. I could export from EyeTV as 16:9 DV, which worked but I got the badly interlaced result. I've found that if I export as HDV 720p 16:9, I get a .mov file that looks good, and it's not a much larger file.

    Now I'm having a problem where the exported file has a glitch. I edited the video in EyeTV, and if I playback in EyeTV it's fine, but when I export the video (so far in every output format I've tried), the resultant file gets messed up when it crosses one of my edit markers. The exported file has a static image (with no audio) for several minutes, then resumes the program, with all the content during the problem interval missing.
     

Share This Page