F Ilife 06

Discussion in 'Mac Apps and Mac App Store' started by derajfast, Jan 17, 2006.

  1. derajfast macrumors 6502a

    Joined:
    Mar 24, 2004
    #1
    Completely messed up my iphoto library...... now when i double click my pictures thumbnail, they open and its a different picture completely.......i am so mad.....i have no idea how i can fix this......
     
  2. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
    First of all: breath! It's not all that bad.

    Try restarting iPhoto holding down command and option to force a rebuild of the library.
     
  3. derajfast thread starter macrumors 6502a

    Joined:
    Mar 24, 2004
    #3
    how do i do that? also, now when i try deleting pcitures from the library, they come back......

    i click the picture, do cmd+del, then it goes to the trash

    then i cmd+del from the trash, and they dissapear from there.....i go back to library, and the pictures are back...
     
  4. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #4
    1) Quit iPhoto
    2) Hold down command (the key with the Apple logo) and the alt key.
    3) Still holding the above click on iPhoto

    A window will appear offering you rebuild options.
     
  5. derajfast thread starter macrumors 6502a

    Joined:
    Mar 24, 2004
    #5
    ok thanks.....what about my deleting problem? im reinstalling ilife 06 now
     
  6. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #6
    The rebuild might well fix that too. Why are you reinstalling it?
     
  7. derajfast thread starter macrumors 6502a

    Joined:
    Mar 24, 2004
    #7
    well the help section doesnt work either.......i think something might have gone wrong
     
  8. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #8
    It's beginning to sound a bit like it! I hope you get it all fixed soon...
     
  9. derajfast thread starter macrumors 6502a

    Joined:
    Mar 24, 2004
    #9
    thanks......im going to be so mad if this doesnt work
     
  10. XNine macrumors 68040

    XNine

    Joined:
    Apr 7, 2005
    Location:
    Why are you wearing that stupid man suit?
    #10
    Please tell me, does your dock die after installation of this iLife 06?
     
  11. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #11
    Mine didn't.
     
  12. derajfast thread starter macrumors 6502a

    Joined:
    Mar 24, 2004
    #12

    it happened to me....and then my computer started locking up, so i restarted, and iphoto messed up
     
  13. XNine macrumors 68040

    XNine

    Joined:
    Apr 7, 2005
    Location:
    Why are you wearing that stupid man suit?
    #13
    That's because the actual RETAIL VERSION shouldn't. The copied or modified single iApp files do infact do this to the dock. BETCHA DIDN'T KNOW THAT!!!! :p
     
  14. derajfast thread starter macrumors 6502a

    Joined:
    Mar 24, 2004
    #14
    hmm im confused? so my copy is bunk? i got the edu discount
     
  15. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #15
    It's the first I heard of it. Hard luck to pirates if it's true...
     
  16. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #16
    If you bought it from Apple it should work as expected (and not kill your Dock or mess up your pictures).
     
  17. derajfast thread starter macrumors 6502a

    Joined:
    Mar 24, 2004
    #17
    but im not a pirate.....i bought mine from the website with the eudcation discount.....and im installing all the apps from the cd
     
  18. XNine macrumors 68040

    XNine

    Joined:
    Apr 7, 2005
    Location:
    Why are you wearing that stupid man suit?
    #18
    If you got the retail disc, it shouldn't be doing this. I'm saying that pirates all over the net are modiying the installation file by only distributing iWeb, or iPhoto, or any of the other apps, ALONE. So you can only install that particular app. And this is a side-effect of that.

    If you have the retail disc and this is happening, then something DEFINATELY is going wrong with your installation. I would honestly re-check your installation settings to be sure everything is okay. Repair permissions, etc before and after too.

    And as robbie said, use the REBUILD ability if anything else goes wrong.
     
  19. derajfast thread starter macrumors 6502a

    Joined:
    Mar 24, 2004
    #19
    well the 2nd install just finished, and it killed the dock for like 30 seconds.....but its working now......let me check out iphoto and see if it works now
     
  20. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #20
    Did the dock freeze once the installation was complete or during the last stage (Optimizing)? If it was during the last stage it was probably just due to update-prebindings using all the CPU...
     
  21. derajfast thread starter macrumors 6502a

    Joined:
    Mar 24, 2004
    #21
    no it didnt freeze......it just dissapeared....but it came back this time.....and now iphoto is still messed up......

    isnt this version of iphoto supposed to organize the folders better than before? because my folders are weird now....
     
  22. XNine macrumors 68040

    XNine

    Joined:
    Apr 7, 2005
    Location:
    Why are you wearing that stupid man suit?
    #22
    What do you mean? How do they look?
     
  23. derajfast thread starter macrumors 6502a

    Joined:
    Mar 24, 2004
    #23
    its like iphoto library--> 200(2 or 3 or 4 or 5), then i click on 1, and theres more subfolders (months i guess) but when i keep going they are like empty
     
  24. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #24
    This version of iPhoto organises the photos differently to previous versions. It means that the first time you run it, it has to rearrange your library. I hope it wasn't the initial rearrangement that messed up your library.

    Don't worry about how iPhoto looks after the photos in Finder for the moment. Try robbieduncan's method for rebuilding the library though. :)
     
  25. JupiterTwo macrumors 6502

    JupiterTwo

    Joined:
    Mar 29, 2003
    Location:
    GB
    #25
    You should have 'Originals' and 'Modified' folders in your iPhoto directory now, which should contain your pictures in year and roll/album folders. The old way was really weird and hard to find your pictures.
     

Share This Page