F8 key launches iTunes in Snow Leopard?

Discussion in 'OS X' started by kirkbross, Jan 10, 2010.

  1. macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #1
    For some reason iTunes launches when I hit the F8 key. I would like to change that but couldn't find it in Universal Access or in iTunes.

    Is this an iTunes or OS X issue?
     
  2. Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    System Preferences > Keyboard > Keyboard Shortcuts maybe?

    As the F8 key is the play/pause key on the current Apple keyboards, it might be a little bit of a problem to assign another function, but maybe the F8 key together with the fn key could work.
     
  3. thread starter macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #3
    Thanks for the reply. yeah, I tried that... F8 is indeed set for Spaces, but it doesn't activate Spaces... it opens iTunes. I'm talking just the plain F8 key (no modifier). It's ever so annoying :(
     
  4. macrumors 6502

    Joined:
    Aug 20, 2009
    #4
    What keyboard are you using? The new Apple keyboards and MBP keyboards have dual functions for the F keys. You need to press the FN key at the bottom left corner along with the F keys in order to activate its secondary function which in this case would be F8.

    The play/pause function does indeed open iTunes for me too but when pressing FN and F8 keys together then it does activate Spaces. If you want to always use the F keys and not its secondary function then in System Preferences > Keyboard you have to check "use all F1, F2, etc keys as standard keys".
     
  5. thread starter macrumors 6502a

    kirkbross

    Joined:
    Mar 6, 2007
    Location:
    Los Angeles
    #5
    The slim aluminum one... just bought it about a month ago (to replace my water-soaked original).

    That worked btw, I didn't have that "use F1, F2, etc.." box checked... checked it and now it's functioning like I want. Thank you! Such a small thing but it was driving me insane.
     
  6. macrumors 6502

    Joined:
    Aug 20, 2009
    #6
    I'm glad your problem is solved. Just remember that now if you want to use the secondary function which for F8 is play/pause in iTunes you have to press the FN key along with the F key you want. You basically reversed it so that the F keys are the primary default keys and the secondary function is only activated when you press the additional FN key. The FN key is used like the Shift key for the symbols above the 1,2,3 number keys.

    I use the rewind, play/pause, fast forward, and volume keys a lot so I actually like it the way it is as default. I just use the FN key whenever I want the F keys.
     
  7. macrumors newbie

    CyberGolem

    Joined:
    Mar 31, 2012
    #7
    Autodesk Maya (or any app for that matter) instead of my software responding appropriately to the F-keys, iTunes rears its ugly little head or icons about the volume adjustments appear.

    I've gone to the prefs and changed the FN pref, but it's not fixing the problem with it either selected or not. Reboots haven't worked either... nor cussing.

    What's maddening is that this problem just started this morning. My computer isn't hooked to the internet so I know it couldn't have been an update. The only thing that may have affected this is that I had turned off the slim-silver-wirelss KB that my mac came with--to conserve the battery life. I use a third party KB since it has a numpad and the wireless mac version doesn't. I've done this in the past (many times), so I'm confused as to why it would act up now... jealousy? :)

    Thanks much,
    CG
     

Share This Page