Facebook "Unable to Load Wall" Error. Help?

Discussion in 'iOS Apps' started by Spongey817, Nov 18, 2009.

  1. macrumors regular

    Joined:
    Jan 4, 2008
    #1
    Hey guys

    As of about two days, my facebook app has been giving me the same two problems:

    1) "Error - Unable to Load Wall" when I go to view my wall

    and

    2) "Error - Unable to load notifications" when I view notifications


    I'm running 3.1.2 with the newest version of facebook. I've tried logging in/out, deleting/reinstalling the app, phone restarts, etc.

    Anyone having the same problem? Know a solution?

    Thanks for your help..
     
  2. thread starter macrumors regular

    Joined:
    Jan 4, 2008
  3. macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #3
    Doesn't happen to me and probably not happening to anyone else, which is why you're not getting a response. You might want to contact Facebook somehow, since it might have something to do with their servers? Have you made sure it works on your computer?
     
  4. thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #4
    Eh, a quick Google search reveals very few people experienced this issue, which is why I thought some of you guys here on MacRumors might have some insight.

    Facebook is definitely working on my computer; it even works through Safari on my iPhone. The app just seems...well, broken.

    Thanks for your reply. Other suggestions / input is welcome...
     
  5. macrumors 601

    Compile 'em all

    Joined:
    Apr 6, 2005
    #5
    May be someone posted something with weird characters on your wall which is causing the problem.
     
  6. thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #6
    I was just about to post this as a possible solution.

    http://www.facebook.com/topic.php?uid=6628568379&topic=11402

    See above link for posts regarding what may be a fix to this issue.

    I'll report back if anything changes...
     
  7. thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #7
    Fixed!

    Solution:

    1) Log into Facebook from a non-apple source (Firefox, IE, Camino, etc).

    2) Go to your wall, look for posts with weird characters (boxes, arrows, etc).

    3) Delete above mentioned posts. Refresh the page.

    4) Facebook on iPhone works fine.

    ...The reason it didn't work for me at first was because I was using Safari on my Macbook. I logged in using Firefox instead and fixed it. Big thanks to the facebook link I provided above for the solution to this issue....
     
  8. macrumors Core

    MacNut

    Joined:
    Jan 4, 2002
    Location:
    CT
    #8
    There is a problem with the app in that it won't display wall posts. Seems it is a wide spread problem.
     
  9. macrumors newbie

    darthkarl

    Joined:
    Oct 24, 2007
    Location:
    Wyoming
    #9
    This is definitely a problem on facebook's end. I can't load my wall on either my iPod Touch's facebook app nor on my Verizon Droid's android facebook app. They both fail.
     
  10. macrumors regular

    Joined:
    Jan 9, 2009
    #10
    Log out of facebook and back in on your phone each time you use it. This often solves it for me. Can't say it'll work for everyone though.
     
  11. macrumors demi-god

    Maskusee

    Joined:
    Sep 30, 2008
    Location:
    Philly
    #11
    Wife and i are having the same issue with Facebook on our iphones.
    Cant view our own profiles (says "Robert has no recent posts") nor any of our friends.

    I logged out of Facebook and logged back in with the same issue.

    I also deleted the app, rebooted the iphone and reinstalled the app, same issue.
     
  12. thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #12
    To those who posted recently:

    I posted a solution above. Try it.
     
  13. macrumors Core

    MacNut

    Joined:
    Jan 4, 2002
    Location:
    CT
    #13
    I think the problem is on Facebook's mobile server.
     
  14. macrumors 603

    nfl46

    Joined:
    Oct 5, 2008
  15. macrumors regular

    Joined:
    Jun 27, 2009
    #15
    Yup. Profile Wall views are fubared. Happens on every wall I try. I just uninstalled and reinstalled the app, so that's not the problem. Appears to be a FB issue.
     
  16. macrumors regular

    Joined:
    Jun 27, 2009
    #16
    FYI, here's the error:

    [​IMG]

    We all know that ain't true.
     
  17. macrumors 68000

    Vandam500

    Joined:
    Sep 29, 2008
    #17
    Same thing here! What gives!!!:mad: and there
    aren't any weird characters! I checked on my desktop
     
  18. macrumors Core

    MacNut

    Joined:
    Jan 4, 2002
    Location:
    CT
  19. macrumors regular

    Joined:
    Dec 14, 2008
    Location:
    In A Galaxy Far, Far Away
    #19
    Same Prob

    I have been having the same problem on my iPhone with my wall. It keeps saying no recent posts.
    Every thing's fine on my Mac though. Must just be an app malfunction.
    As long as Bejewled Blitz works, I'm okay. :p
     
  20. thread starter macrumors regular

    Joined:
    Jan 4, 2008
    #20
    Make sure you access Facebook from a browser other than Safari. The error, for me at least, didn't show up on Safari, but did on Firefox. From there, it can be easily fixed.
     
  21. macrumors regular

    Joined:
    Dec 14, 2008
    Location:
    In A Galaxy Far, Far Away

Share This Page