Fan issues MBA 2012

Discussion in 'MacBook Air' started by Pavel08, Dec 28, 2012.

  1. macrumors newbie

    Joined:
    Dec 28, 2012
    #1
    Hello. In summer I bought the new MBA (2.0 GHz with turbo up to 3.1 i7, 8 GB RAM, Intel HD Graphics 4000 512 MB).

    At the beginning I could never hear the fans spinning. It was completely silent. Its still is, unless i start watching some videos online. Then its just a nightmare. The fans are going crazy and its really noisy. Its been like that for a couple of months already. Im so tired of it.

    For example the week after i got my MBA i watched like 30 episodes of Big Bang Theory online and I never heard the fans. But now, if I go to the same website and start watching them again, the fans gets really noisy only after 20 minutes.

    I checked activity monitor for 1080p video on youtube. Whenever I view a video in 1080p the Flash Player is always staying at around 107% of CPU. If i pause the video, the cpu is back to normal. Ive attached some screenshots.
    What is the problem? How can I fix it? Im so tired of that noise. I would really appreciate if somebody would help me.
     

    Attached Files:

  2. macrumors 6502

    Joined:
    Jun 26, 2012
    Location:
    Virginia, USA
    #2
    That's normal. Nothing to fix.
     
  3. thread starter macrumors newbie

    Joined:
    Dec 28, 2012
    #3
    Are you kidding me? 107% CPU while watching a video is normal? Then why I never had these issues for the first two months after i bought my MBA?

    Even my old crapy windows laptop from 2006 had much less noise while watching 1080p video. Is MBA really that bad?
     
  4. thread starter macrumors newbie

    Joined:
    Dec 28, 2012
    #4
    Is it really normal?
     
  5. macrumors 6502

    Joined:
    Apr 8, 2010
    #5
    i just got a new macbook air replacement and i'm noticing it doesn't run dead quite when idle like the other airs i tried, kinda disappointing
     
  6. macrumors 6502

    Joined:
    Dec 23, 2010
    #6
    you could try installing the latest flash player edition from adobe. alternatively, go for the html5 trial on youtube. see if that makes a difference.

    do you have smcfancontrol installed? could also help in ensuring your mac doesn't get too warm.
     
  7. macrumors 6502

    Joined:
    Jan 5, 2005
    Location:
    England
    #7
    Yes, it's normal. Flash is rubbish.

    If you're old windows Laptop can even attempt to play 1080p flash video I'm impressed.

    Just opt into the YouTube HTML5 view and you'll be fine.
     
  8. macrumors 6502

    Joined:
    Apr 19, 2012
    #8
    Yes it is normal for flash to use alot of cpu cycles. Theres a reason Apple no long pre installs it. It also leads to horrible battery performance.

    Install the ClicktoPlugin for safari and that will disable most flash things until you click on them which should give you the rated battery life. It will also work seamlessly with youtube to try and play most videos in HTML5 if the native youtube player isn't in HTML5 for that video.

    I highly doubt that your 2006 laptop can play 1080p video effortlessly as hardware decoders for videos werent that popular yet :D

    Lastly, your fan maybe reacting more to the increased temps because of dust build up. This would explain why the fans could cool the computer down with less speed when you first got it but now it needs to run faster to keep it the same temps due to dust building up.

    One thing you can try is to uninstall flash then reinstall the newest version and install Clicktoplugin for Safari. This should give you the best battery life and performance.
     
  9. macrumors 6502

    Joined:
    Apr 19, 2012
    #9
    Just ran a test for you to show you the different between using flash and HTML5. The native HTML5 player for youtube can be found here http://www.youtube.com/html5

    I still highly suggest that you install clicktoplugin so that anything you may come across can be played in HTML5 even if the website doesn't have a setting for it.

    First one is flash playing a 1080p video and the 2nd is HTML5 playing the same 1080 video.
     

    Attached Files:

  10. macrumors 604

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #10
    Yeah - Flash runs really rubbishy on OSX. It's much better on Windows.

     
  11. thread starter macrumors newbie

    Joined:
    Dec 28, 2012
    #11
    Thank you very much for your response. Im sorry the old laptop is from 2008, but still its "fat and ugly". I did install ClickToPlugin and I can feel the difference. Atleast youtube is running smoothly now. Ive noticed there were a lot of options in the ClickToPlugin menu. Do I need to do anything more besides the standard options to get a better performance? Are there any drawbacks using ClickToPlugin(like will quality be worse if using HTML5)?

    Also is there any way to clean the fans from dust?
     
  12. macrumors 6502

    Joined:
    Apr 19, 2012
    #12
    If you read the clicktoplugin page it has some explanations on what the other settings do and it would be up to you to choose which ones to enable. Otherwise it works fine out of the box if you do not want to tinker with it. I don't think there are any drawbacks to it since it uses the source file and plays it with Safari's built in quicktime player (you can see this in action by looking at the play button and controls on a video and they will be black and match the Quicktime program.) By default it will try to play any youtube video at 1080p if it can so if you notice your videos loading slowly you can change that in the settings. Another way to change it is to hover your cursor over the top left area of the video when it is using the html5 player and you can select the video quality there.

    For cleaning the fan you can use any canned compressed air that you can get anywhere.
     

Share This Page