file requires stuffit 8

Discussion in 'Mac Apps and Mac App Store' started by kirkw, Nov 3, 2003.

  1. kirkw macrumors newbie

    Joined:
    Oct 29, 2003
    #1
    I am fighting with stuffit over a .sit file. I have version Stuffit version 8 installed but keep getting the error "Sorry, Expander requires Stuffit Engine 8.0.0 or later. Please reinstall...."

    It looks to me as if there are several versions of stuffit installed on this machine (was 10.2.7, just upgraded to 10.3). Specifically the stuffit engine in /disk0/System_Folder/Extensions/ looks to be 6.0.

    Is there any way to get rid of all the older stuffit stuff? or better yet can I unpack .sit files with tar?
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    Re: file requires stuffit 8

    The MacOS X 10.3 installer seems install Stuffit Expander 7.0.3 at the expense of any other version you may have. The workaround is to reinstall version 8. I did it. It didn't hurt a bit.
     
  3. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #3
    Yes, when someone wrote the installation script, they didn't check the version of Stuffit components.

    Re-installation of version 8 worked for me as well.
     
  4. kirkw thread starter macrumors newbie

    Joined:
    Oct 29, 2003
    #4
    where did you re-install from. The first thing I tried was re-installing version 8, but the stuffit_std_8_x_install.sit asked for version 8 in order to unpack as well... kind of circular...
     
  5. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #5
    That file can be unstuffed using Stuffit Expander 7. You should be able to drag it to the Stuffit Expander 7 icon to unstuff it. Then you can rerun the Stuffit STD 8.0 Installer. After that, run the Stuffit 8.0.1 Updater.
     

Share This Page