File Sharing Between Mac and Windows 7

Discussion in 'OS X' started by darkpixie08, Jun 14, 2011.

  1. macrumors member

    Joined:
    Sep 6, 2006
    #1
    I posted this on the basics and help forum, but no one seems to be able to help. So I thought I'd post it over here.

    I have a mac mini running 10.3.9 and a windows 7 computer that I would like to fileshare between. They are both on the same wireless network, but can not seem to connect between the two of them (I can't even see the mac on the windows computer). I have gone to system preferences on the Mac Mini and turned on all the file sharing options. Is there some other step that I'm missing? This really should not be that difficult, right? If someone could walk me through this like I'm five years old, I'd really appreciate it.
     
  2. Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    You would think it would be easy but for some reason my Macs has trouble connecting to my PCs. The easiest solution for me was to use dropbox which sync'd the files I wanted
     
  3. r0k
    macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #3
    In system preferences, look for an option to turn on "SMB" (Windows) file sharing. We got rid of the last of our windows boxes so I can't check this out myself but back when we had XP and OS X, turning on SMB worked fine. You also need to look at the OS X firewall. If it's on, try turning it off long enough to test file sharing. You then know you need to tweak firewall settings to allow file sharing.

    The root cause of many of these problems lies with the network "browsing" windows uses and OS X uses. Windows browsing is somewhat intermittent at best and historically one version of windows would get into catfights with another version of windows about who should be the "master browser". Meanwhile bonjour (Apple's network browsing) is somewhat clueless when it comes to changing IP addresses so I set static IP addresses for all my NAS (Network Attached Storage) and machines I want to be able to screen share without re-scanning to find their new IP address.

    Here it is step by step:

    1 - on windows - temporarily disable the firewall
    2 - on OS X - temporarily disable the firewall
    3 - on OS X - in system preferences under sharing, enable SMB file sharing
    4a - on windows - try putting in the ip address of the mac you are trying to connect to ( I think you can do this in windows explorer's "url bar")
    OR
    4b - on OS X - in finder - select go->connect to server and try putting in smb://ip.address of the windows box you are trying to connect to.

    The OS X firewall middle setting is the most severe. (From memory) I think the third setting is the one that is more flexible and the middle setting is the one that is most severe: "allow only essential services". To get SMB sharing with windows working, you will wind up with the firewall either off or set to a less severe setting.

    Apple provides help connecting to Windows from a Mac here.

    Microsoft provides a form where you can get help connecting Win 7 to a Mac here.

    Other debugging steps you can take:
    ping
    on the windows box, in cmd type the following:
    ping ip.address (of the mac you are trying to connect to)
    on the mac, in terminal type the following:
    ping ip.address (of the windows box you are trying to connect to)


    ftp
    in system preferences->sharing, enable ftp on the Mac and from the windows box, in cmd type the following:
    ftp ip.address (of the mac you are trying to connect to)

    Remember to disable ftp if you no longer need it so if you are ever in a public hotspot you don't have to run the risk of somebody trying to gain access to your Mac via ftp.

    Note that you can find out your ip address on Windows by typing "ipconfig" in cmd and on OS X by typing "ifconfig" in terminal.
     
  4. macrumors newbie

    Joined:
    Aug 27, 2010
    #4
    I am hoping I can improve on an annoying situation:

    I am able to connect from Snow Leopard to Windows 7 without any problems.

    The Windows 7 machine can see the Snow Leopard but only sees the account that is not password-protected. I can't figure out a way to force Windows 7 to ask for a password so that I can connect to the password-protected Mac account. Thoughts?

    Mac Settings:
    File Sharing: On
    Pwd-Protected Account Public Folder: Everyone Read & Write
    Share using AFP checked
    Share using SMB checked
    Turned on user account SMB sharing for pwd-protected account, but not for the unprotected account

    I'd rather not turn off AFP because my old Tiger iMac seems to handle that protocol better.
     
  5. macrumors newbie

    Joined:
    Aug 27, 2010
    #5
  6. macrumors 6502a

    monkeybagel

    Joined:
    Jul 24, 2011
    Location:
    United States
    #6
    How far are you getting? Is the Windows computer prompting you for credentials? You may need to disable SMB signing on the Windows computer to connect to 10.3.9, since it is an older version of OS X.
     
  7. macrumors member

    US Marine

    Joined:
    Nov 21, 2010
    Location:
    Charleston, SC
    #7
    Sorry for necro-bump, but I'm having a problem doing this as well. I'm running OS X Lion on my MBP and Windows 7 x64 on my PC.
    I can't actually enable file sharing on the Mac. When I click the check box, it goes gray for a slit-second (to acknowledge that I clicked it), but it won't check. Any ideas?
     

Share This Page