File Sharing between Windows 7 and OS X

Discussion in 'OS X' started by XedLos, Feb 1, 2009.

  1. macrumors member

    Joined:
    Dec 6, 2008
    #1
    I want to connect to windows 7 via OS X. I cant see the windows 7 machine in finder although its on the network. So i tried to connect to server but it asks me for a username and password but i dont have one on the winows 7 machine.

    I have a home group created by windows 7 and i tried using teh code windows 7 gave me but i had no luck.
    How can i connect to my windows machine?
     
  2. macrumors newbie

    Joined:
    Feb 6, 2009
    #2
    Same Problem

    Yeah i was also wondering if anybody figured out how file share between mac os and windows7.. thanks in advance
     
  3. macrumors 68000

    VPrime

    Joined:
    Dec 19, 2008
    Location:
    London Ontario
    #3
    Works fine for me.
    When you connect manually(smb://iphere) and it asks for password, just select Guest.
     
  4. macrumors newbie

    Joined:
    Feb 6, 2009
    #4
    Thanks

    Ok thanks, i am kind of new to macs so i did not think on connecting manually with smb. I was hoping for windows7 to just be able to find my mac through the new homegroup option and just take it from there, ohh well cant have it all in life. But anyways now i am able to share files from my mac to windows 7. thanks for the tip.
     
  5. macrumors newbie

    BrutalSpoon

    Joined:
    Dec 2, 2007
    Location:
    London, UK
    #5
    I've been having a slightly different problem - I'm running a PC which dual boots Vista and the Windows 7 beta. I can connect fine with my MacBook to Vista via SMB, but trying to connect to Windows 7 the same way comes up with nothing at all - it just times out after a few minutes. I've enabled all sharing options, made sure there's no firewall settings blocking access, and the windows troubleshooter can't find anything wrong (and yes, I'm sure I'm using the right IP address :p).

    Any suggestions? I really don't want to have to boot into Vista every time I want to grab some files off my big internal drive.

    Thanks in advance.
     
  6. macrumors newbie

    Joined:
    Mar 2, 2009
    #6
    Say What?

    I saw the answer to "connect manually with smb....." but as a Newbie I don't know what that means? I want to share my Windows 7 machine with my networked MAC. Could someone walk me thru the solution?

    Thanks,

    TheOldDude
     
  7. macrumors 68000

    VPrime

    Joined:
    Dec 19, 2008
    Location:
    London Ontario
    #7
    If every thing is fine on your windows side (Ie. have file sharing on, and some folders shared)
    Then in finder just go to GO (in the menubar at the top) and select Connect to server.
    Or press cmd+K

    In the window that pops up type in smb://windows_computer_IP_here (Or you can enter the computer name..but entering the name does not always work for me)
     
  8. macrumors member

    Joined:
    Feb 2, 2009
    #8
    I'm sorry for reviving an old thread, but it deals exactly with what my issue is.

    When I had windows XP, my Mac would automatically detect my windows shared folders. I didn't have to go to Connect to Server and type in my samba address. After having installed Windows 7, my other Windows 7 and my Windows XP machines still automatically detect the shared folders, but as has been stated in this thread, now I have to go to Connect to Server.

    Does anyone know how this could be made automatic? When I do it manually through 'Connect to Server', it works perfectly, however, I would prefer if it were automatic, it added that luxury and comfort that I expect from my Mac, and it's kinda sad to have it taken away just like that.

    Thank you guys, I would appreciate any help!
     
  9. macrumors newbie

    BrutalSpoon

    Joined:
    Dec 2, 2007
    Location:
    London, UK
    #9
    I'd also like to see the answer to this - I did manage to get sharing working in the end (although it was so long ago that I can't quite remember what I ended up changing :rolleyes:), but I still have to cmd+k in, which isn't necessarily ideal :(

    After I've connected manually, the PC shows up both under its IP address and under its own name (as if it had connected automatically).
     
  10. macrumors 6502a

    PurrBall

    Joined:
    Oct 25, 2007
    Location:
    Indianapolis
    #10
    My Win7 machines are popping up in Finder just fine.
     
  11. macrumors 68030

    blackhand1001

    Joined:
    Jan 6, 2009
    #11
    I have found that Windows OS X sharing is very inconsistent and Apple should really work on improving this. Setting up printer shares can be downright painful sometimes.
     
  12. macrumors 6502

    Joined:
    Mar 9, 2008
    Location:
    Brisbane, Australia
    #12
    Hi Blaenk, BrutalSpoon,

    When you have your volume mounted (cmd+k) go to (Sys Pref ->Accounts -> Login Items), and drag your Windows volume onto the list. See if that works.

    Good luck, Maw.
     
  13. macrumors G4

    Joined:
    Jul 17, 2002
    Location:
    USA
    #13
    You do understand that Windows 7 is still in development, don't you? Wouldn't you think that the onus is on Microsoft to ensure that its proprietary network stack remains compatible with others across versions?
     
  14. macrumors 65816

    Joined:
    Apr 5, 2009
    Location:
    Kyoto, Japan
    #14
    This isn't automatic, but it may be better than doing it manually: do the maunal connection one time, make an alias of the mounted share (drag the share to the trash or select it & Cmnd-key E to dismount it), store that alias somewhere convenient, drag that alias to the sidebar of a finder window, click on that alias or the sidebar icon -- did the share mount again? This method works for Apple shares, but I haven't tried it for a Windows share, so I am not positive it will work.
    Good Luck
     
  15. macrumors member

    Joined:
    Feb 2, 2009
    #15
    I have a feeling that it might have 'broken' when I was trying to 'fix it', so I am going to try what is mentioned in this post: resetting my network configuration. I hope it works and will let you guys know.

    On the windows 7 end, I already set everything to on, I lowered the encryption from 128-bit to the other lower one, and I turned on password-less connections. Everything is basically 'open' here, and yes, when I do CMD+K it does work. But like I said I would like it to be automatic like it was with Windows XP. I don't really want to add it to my autostart actions since I won't always be at home and don't want to see an error dialog whenever I'm not (Or does that not happen?)

    Thanks for the help so far.
     
  16. macrumors newbie

    Joined:
    Jun 21, 2009
    #16
    ALMOST solved all my problems

    I googled this post when I had problems connecting my MacBook with OS X on it with my Win 7 at it's most updated version.
    The manual smb connection method made it possible to connect to my "Users" folder on the win7, BUT...
    When I try to share other folders (such as My Music folder.. which in my case is located under "a_different_logical_partition:\my_username\My Music"), the mac tells me:
    "A volume failed to mount
    The volume "My Music" could not be mounted"

    While connecting I used the following method:
    - cmd+k
    - Server Address: smb://win7_computer_name
    - Press Connect
    - I entered my username and the password which I've set in advance on the win7 side
    - "Select the volumes to mount:" --> As mentioned, when I select "Users" it connects just fine; But when I try to select the other shared folders it can't connect.

    Pleeeeease can someone find me the proper solution? *beg* :confused::eek:

    :apple::rolleyes:
     
  17. macrumors 65816

    Joined:
    Sep 3, 2006
    #17
    I have the same problem.
    No solution yet?

    I also have to say that eventhough it connects to 'users' folder, I can copy from win 7 'users' folder to my mac, but I cannot copy files from my mac to win7 'users' folder.

    'You may need to enter the name and password for an administrator on this computer to change the item named 'filename'.

    I click 'continue'.

    Then my mac displays:

    ' The item 'filename' contains one or more items you do not have permission to read. Do you want to copy the items you are allowed to read? '

    I click 'continue'.
    Then my mac displays:

    'The operation cannot be completed because you do not have sufficient privileges for some of the items.'

    And that's all! No copying files from mac to win7 'users' folder.


    All sharing option on win7 are enabled.


    So, what can we do to have a proper file sharing?
     
  18. macrumors newbie

    Joined:
    Aug 1, 2009
    #18
    solution :)

    I have the same situation. What you've got to do is go to wherever you have the folder you want to share on win7, right click the folder and click share -> share with... -> specific people. It will open up a window for you to type in a specific person but just leave the field blank and press share.

    Now when you smb connect, that folder should show up with users :):D
     
  19. macrumors 65816

    Joined:
    Sep 3, 2006
    #19
    In fact, the only folder I am able to share in win7, that is connected with mac (finder,go,connect to server) is the win7 folder 'users'.

    I shared the whole 'c' folder of win7 pc in the same way that 'users' folder does, but with no luck.
     
  20. macrumors 6502a

    PurrBall

    Joined:
    Oct 25, 2007
    Location:
    Indianapolis
    #20
    I found that I had to go into the sharing properties and add permissions for Guests and Everyone to have full control (or read only if thats what floats your boat) for Win7 shares to work properly.
     
  21. macrumors newbie

    BrutalSpoon

    Joined:
    Dec 2, 2007
    Location:
    London, UK
    #21
    I'm assuming this is instead of right click -> Properties -> Sharing -> Advanced Sharing (which acts just like folder sharing in XP/Vista)? I found that this worked fine for me and I didn't need to mess around with permissions at all.
     
  22. macrumors 601

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #22
    Make sure you are all using the same DNS server and same Time Server that you are sharing with. Plus open System Preferences->Network, Advanced button and there select the tab for WINS and put in the Work Group name of the Windows workgroup.

    Plus here is another sharing how to site.
     
  23. macrumors member

    Joined:
    Dec 13, 2009
    #23
    this works for me... but, with XP, I was able to see the computer name in finder and did not have to talk IP addressing command mumbo jumbo ;-). what changed? tks much
     
  24. macrumors 604

    thejadedmonkey

    Joined:
    May 28, 2005
    Location:
    Pa
    #24
    Uh huh. Apple told me it was impossible to do, reliably, when Leopard first came out. I think if you have bonjour installed on the Windows machine, there's a better chance, but it's just that - a chance.
     
  25. macrumors newbie

    Joined:
    Dec 28, 2009
    #25
    How to see windows 7 PC Automatically from your macbook

    I figured out how to make it auto detect your windows 7 computer on your macbook.

    Do the following after you have done everything on both sides to get it ready for sharing and you just can't figure out why your mac won't see your windows 7 pc but you see your mac from your windows 7 pc. (this was my problem)


    Go to the airport network preferences. Then click advanced and after that the WINS tab select your workgroup and then put in the ip address of your windows computer. This should make it auto detect your windows 7 pc.

    p.s. I'm running leopard


    hope this works for you, I searched for hours and finally just though I would try it myself and I finally got this way to work
     

Share This Page