Final Cut Pro X has gotten incredibly slower

Discussion in 'Mac Apps and Mac App Store' started by horace528, Mar 30, 2013.

  1. horace528
    Expand Collapse
    macrumors regular

    Joined:
    May 14, 2011
    #1
    Recently, my FCPX application has been acting really slowly. Whenever I try to start a new project or a event, it would just put me up with the bouncing beach ball of death, and would take a very long time before it even responds.
    Also, even after all this madness, it's not over. FCPX would never allow me to actually even start editing. It won't even let me drag a clip in the timeline.
    I really don't know what's wrong. I tried reinstalling, and even just restarting the computer, but nothing has resolved the problem yet. FCPX had always worked with me in the past, but suddenly, it's like this.
    Anybody knows like a solution or at least anything that would help out? I really need to start a new project, and fast, but this is really getting me into now... :mad:
     
  2. BrianBaughn
    Expand Collapse
    macrumors 68040

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    Try running it in a new user account and see if it improves.
     
  3. horace528
    Expand Collapse
    thread starter macrumors regular

    Joined:
    May 14, 2011
    #3
    I already tried this, but it really still does not work.
    Any other thoughts? :confused:
     
  4. br3nt
    Expand Collapse
    macrumors member

    Joined:
    Jul 1, 2012
    #4
    have you done the usual? Repair permission in disk utility and maybe SMC reset? :eek:
     
  5. horace528
    Expand Collapse
    thread starter macrumors regular

    Joined:
    May 14, 2011
    #5
    I tried the disk repair option, and it's the same.
    Better try that SMC reset. Also, I'm thinking that it could also hold some corrupt video files, so planning to fix them soon.
     

Share This Page