1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Finder Assist for NTSF External drive

Discussion in 'OS X Mountain Lion (10.8)' started by VRevs, Jul 18, 2013.

  1. macrumors newbie

    #1
    Firstly, please note the problem only persist on NTSF external drive. Mac Ox Extended external drive don't have this problem.

    I recently update my Macbook Pro Snow Leopard (10.6.8) to Mountain Lion (10.8.4).
    The finder search function seem to break once I upgrade to the latest OS.

    Searching files from macbook itself is okay. However, any search on the NTSF external hard drive yields no result at all.

    Harddrive Info:
    NTSF drive. (I switch between window and Mac a lot)
    I used 'Paragon' to read/write in Snow Leopard. I have since uninstall the Paragon as Mountain Lion seem to be able to read/write NTSF drive without any 3rd party software.
    I have the same problem 'with' or 'without' the paragon software.

    I tried using Spotlight 'Privacy' to refresh the index but yield no result. Do anyone have a fix for this problem?

    Again, please note that the problem only occurs on NTSF external drive. I don't really want to reformat all my drive as I need them for Window.

    Thanks in advance.
     
  2. macrumors demi-god

    wrldwzrd89

    #2
    This is happening because NTFS drives (not NTSF) default to read-only in Mountain Lion. Did you by chance use MacFUSE for Snow Leopard to enable writing to your drive? This doesn't work in Mountain Lion, but alternatives to it do exist.
     
  3. VRevs, Jul 19, 2013
    Last edited: Jul 19, 2013

    macrumors newbie

    #3
    I used Paragon (ver 8) for Snow Leopard.

    Tried downloading the latest demo version (ver 10) for mountain lion but still give no result.

    Is there any alternative?

    I actually tried installing Path Finder (Demo ver). It can search all the files in the NTFS drive. If else fail, I might just have to cough out another $39.95 USD for the software... :(
     
  4. macrumors demi-god

    wrldwzrd89

    #4
    I'm assuming you're using Spotlight (or a 3rd-party app powered by Spotlight) for search. Spotlight depends on being able to write its index to the drive to be searched. If it can't do that, search will fail.
     
  5. macrumors newbie

    #5
    Hmm...That might be the case..

    What I don't get is why something that was good and well in Snow Leopard have to break in Mountain Lion.. this seem to be a step back in search functions.

    Is there any way to fix this other than;

    1) Revert back to Snow Leopard (I like mountain lion so far... other than the spotlight search)

    2) Look for an alternate Finder apps.
    - Path Finder seem to be a good alternative. Quite expensive though.

    PS: I found that Mountain Lion only let you read/copy file into NTFS drive. Can't even rename folder. Back to using Paragon.
     
  6. macrumors demi-god

    wrldwzrd89

    #6
    It boils down to kernel-level changes. Most notably, the kernel is now 64-bit for ALL Macs, which causes all 32-bit Kernel Extensions to break.
     
  7. macrumors newbie

    #7
    I see...
    Is there anyway to fix this?
    Or I just have to wait for Mac to come out with the fix... (hopefully) :(
     
  8. macrumors 603

    blueroom

    #8
    Try formatting the drive to exFAT or consider getting a NAS.
     
  9. macrumors newbie

    #9
    Thanks blueroom, exFAT solves the finder issue. And it works on window too.

    Now I just need to transfer all my files elsewhere while I reformat all my harddisk.
     

Share This Page