Finder disconnects mounted network folder after some time

Discussion in 'Mac OS X Server, Xserve, and Networking' started by robertpolson, Jan 20, 2013.

  1. robertpolson, Jan 20, 2013
    Last edited: Jan 20, 2013

    macrumors member

    Feb 24, 2011
    1. I mounted the Multimedia folder from my Qnap NAS by dragging and dropping it to FInder's sidebar (AFP protocol).

    2. I also added this mounted folder to my Login Items in System Settings so that this folder will be mounted automatically on login.


    After some time Finder drops connection to my shared folder. I can still see the folder but when I click it to access it, it takes a few seconds for finder to connect to that folder again. This creates a problem for both, iTunes and Plex since my media is stored on my Qnap. iTunes and Plex "think" that the Multimedia folder is unavailable and I have to manually click the Multimedia folder in Finder to connect to it before I can use iTunes or Plex. This is very annoying.

    Is this some kind of bug, a network setting, or system setting? How can make sure that Finder always stays connected to my shared mounted NAS folder?


    OSX - Mountain Lion
    Qnap firmware version: 3.8.1 Build 20121205
  2. macrumors 601


    Feb 19, 2008
    The Finger Lakes Region
    This sounds like the drive is sleeping to save energy.
  3. thread starter macrumors member

    Feb 24, 2011
    I am testing my connection with NFS share instead of AFP right now. What I have noticed so far is that with NFS my mac connects to the shared folder almost instantly but with AFP it takes about 10 - 20 seconds to connects almost every time I click on the shared folder. I think that there is also a big problem with Qnap and AFP. I am not sure if SMB is better than NFS.

    Any thoughts?
  4. thread starter macrumors member

    Feb 24, 2011

Share This Page