Finder not responding help for a newbie

Discussion in 'OS X Mountain Lion (10.8)' started by RebornTheGame, Dec 9, 2012.

  1. macrumors member


    Jun 1, 2012
    Qld, Australia
    I cannot be sure when my woes first started, but the last few days I have realized that I have an intermittent problem where the Finder starts 'not responding'. It then locks up the software that is trying to use Finder (eg Save As with Outlook, MS Word, Adobe CS).

    I am not which is the chicken and the egg here, but I have noticed that my Time Machine sits looking for the backup folder on my Time Capsule.

    Sometimes this prevents me for shutting down my machine correctly.

    I have tried using Disk Utility to do a repair disk and repair disk permissions. Both now indicate the machine is clean.

    I am on a rMBP and using ML10.8.2.

    I am new to OSX - having started using it in July 2012.

    I have been telling all my Window friends how stable and wonderful life is on a Mac, but now I am wondering if the joke is on me.

    Can anyone suggest anything I haven't already tried?
  2. macrumors 603


    There are many things you can do to solve this.

    But what you should do first is empty your caches.

    Empty the following folders and restart.


    There are two places more where there are caches but start here first.
  3. thread starter macrumors member


    Jun 1, 2012
    Qld, Australia
    Thank you so much for replying justperry. The system wouldn't let delete all of the files / folders in those locations. Is that significant?

    Problem is still in effect


    Gary Alen
  4. macrumors 603


    You can delete them but after you select all those items in that folder and dragged them to the trash the system will ask you for a password, if not that is strange.
    Enter password and they should be deleted.
    Report back if this is not the case.

    P.S. You went offline fast, I can see if someone replies to me so better try to sit down instead of going offline.
    I am more or less in the same timezone, 1000 Km north from Darwin so I am online when you are.
  5. thread starter macrumors member


    Jun 1, 2012
    Qld, Australia
    Thank you again. Those cache folders are now empty, but the problem seems to persist.

    I am away from the computer for 30mins, but I'll otherwise stay online.

    What do you think is the root of this problem?
  6. macrumors 6502a

    Sep 10, 2012
    RE: network problems?

    Hi RebornTheGame and justperry,

    justperry: I hope you don't mind my asking a couple questions? (I liked your suggestion of deleting the caches, by the way.)

    RebornTheGame: Let me reiterate your problem just to be sure I have an intermittent problem with stuck/crashed Finder windows: initially they work fine but then at some point you find that the Finder windows have crashed? What happens if you "killall Finder" in a terminal window at this point? Do the Finder windows come back active? When this problem occurs, can you still use commandline commands in a Terminal window? ... or has your OS crashed completely? ... or has the WindowServer crashed? If you have another computer handy, can you ssh to your rMBP when it's having this problem? Can you ping your rMBP from another computer?

    RebornTheGame: Are you having the same problem in both cases you describe? You mention that TM cannot reach your TC when you have this trouble, and the TC must be a network drive. When you have the trouble with "Save As...", are you also trying to save to a network drive? If so, then you need to check your network connections when you have this problem, perhaps with Apple's WiFi (hold down the alt/option key while clicking on the Wireless icon in the top menu bar, then Open WiFi Diagnostics). See if you are losing signal strength, perhaps because of radio interference? Or perhaps you are having a DNS problem? Is your DNS server up and working properly? Can you ping your router, ISP gateway, DNS server, and an external Internet hostname such as

    RebornTheGame: The other thing that I'd look into is to do a "top -o cpu" or use the Activity when you have this problem, and see what other processes are running and if any of them is fully utilizing your CPUs or your network. Do you see any Disk Activity at the time you cannot reach your TC?

    RebornTheGame: You might think about booting into single user or safe mode and see if the problem arises then.

    RebornTheGame: If you haven't identified the problem at this point, you might then consider doing an Apple Hardware Test.

    ...just some thoughts on how to proceed...

    Good luck,
  7. RebornTheGame, Dec 9, 2012
    Last edited: Dec 9, 2012

    thread starter macrumors member


    Jun 1, 2012
    Qld, Australia
    Hi Switon

    Many thanks for your input here.

    I am such a newbie I have never used the terminal window or know how to even open it. Sad I know.

    To clarify what happens:

    1. When I tell a program like MS Word to save as, the coloured wheel appears (before I see the new window to select a destination) 75% of the time I have had the spinning coloured wheel appear. From then on, until I restart the same thing happens.

    2. When I have had that happen with a program, command+option+escape says that the program is not responding.

    3. When I then try to restart or shut down, the MBP won't close all the way. A command+option+escape shows the Finder is 'not responding'. If I tell it to relaunch 80% of the time it will shut down the MBP all the way.

    4. If use Finder or Pathfinder, before I have had one of the issues above happen, it will happily show me the TC and I can open the folders on it. My wife's MBP is also happily using that TC. I am pretty sure it's not a network issue.

    Everything has been working fine for me the last 5 odd months.

    Kind regards

  8. macrumors 603


    Two things.

    If you disconnect the TimeMachine/Capsule drive does it still happens, do you still have the same problems?

    Have you tried another User Account?

    About another User Account, if there is something wrong in your User account you can test this by logging into another User Account, now if you don't have one create one in System Preferences in Users and groups, after this log into the new User Account and try if you have the same problems again, do this with the same setup as your normal User account so keep the time machine connected.
    Are the problems gone in the other User Account?
    If yes there is a problem in your normal User Account and I will tell you what to do next.

    No I don't mind, we are all to help here, don't worry.
  9. thread starter macrumors member


    Jun 1, 2012
    Qld, Australia
    Just a very quick report back. Yes it does continue to happen with the TC disconnected.

    I will try the different user account and report back.

    You are both incredibly patient and generous with your time.
  10. macrumors 603


    No worries, I have all day.

    The reason to start in another User Account is if it does not happen there it is User related, not system wide.
    That is the first thing to do when problems like this one occur.
  11. thread starter macrumors member


    Jun 1, 2012
    Qld, Australia
    Okay good tip for future trouble shooting.

    I created a new user, rebooted and logged in as the new user.

    This is what happened:

    1. The few save as and opens worked okay - though these don't always 'not responding' fail for my ordinary (administrator account).

    2. The TC sat saying looking for backup for quite a time.

    3. When I tried to restart it sat on the white screen for a while. When I command+option+esc it said Finder (Not responding). I told it to relaunch. The Finder disappeared from the list. There was a spinning dark grey wheel. After quite a while waiting I forced the MBP to power down.

    I am not sure how illuminating that is.
  12. macrumors 603


    So, it didn't really help?

    Now, there are other things you can do.

    Reset SMC and clear the PRAM.

    Reset PRAM
    Hold Command-Option-P-R keys on Start up.
    OS X Mountain Lion: Reset your computer’s PRAM

    Reset SMC
    Intel-based Macs: Resetting the System Management Controller (SMC)

    If this does not help clear the caches as before but now also two other places:

    Clear ALL caches
    ~Home/Caches----Delete All files and Folders here
    /Library/Caches----Delete All files and Folders here
    /System/Library/Caches----Delete All files and Folders here
    /private/var/folders----Delete all folders inside this folder(2 or more dependable on how many users)

    Note: if you don't see the private and system folder navigate to it by clicking go in finder and select go to folder, then enter the path(1. /System/Library/Caches and 2. /private/var/folders)
  13. thread starter macrumors member


    Jun 1, 2012
    Qld, Australia
    Okay... first to check if something is significant and then to ask a really embarrassing question:

    1. I reset SMC and cleared PRAM. No joy. When I started deleting the contents of Cache folders (eg /Library/Cache) I got the spinning wheel + Finder (Not Responding). Is that significant.

    2. When you say ~Home/Caches where do I find that location?
  14. macrumors 603


    1. No, you have more issues with Finder so it seems it's not responding with whatever you do.

    2. ~/Home as in your Home folder or /Users/yourname

    Now, it seems you have a fair bit of problems, you could also try and redo the OS update, you can not use Software Update for this but have to go to Apple's software page, download the last combo and run it manually.

    I will update this post within 5 minutes and give you the link.

    Edit: OS X Mountain Lion Update v10.8.2 (Combo)
  15. thread starter macrumors member


    Jun 1, 2012
    Qld, Australia
    I don't have a caches folder inside /users/gary


    Also when I tried to manually download the update using FF I got the message "/Users/gary/Downloads could not be saved, because an unknown error occurred."

    But it seems to be downloading using Safari
  16. macrumors 603


    Sorry, /users/gary/Library/caches ( though I said ~/Home/Library/Caches before-~home=/Users/gary)

    Hm, can not be saved, that is odd, you might have a permission problem with your home folder.
    (Click on the Downloads folder and then get info, see screenshot, should be similar)
    (Also check info for Gary and Library)
    In Safari's Preferences you can change the download folder to a different place, try to set it to Desktop, does it safe now?

    Attached Files:

  17. thread starter macrumors member


    Jun 1, 2012
    Qld, Australia
    Just to bring you up to date...

    1. I have ensured that all of those cache folders are empty.

    2. When I Get Info for the gary directory there are a few entries, one is me, the administrator is not listed.

    3. I have path finder installed, so when I try to Get Info on the Library and Downloads folder, its version of Get Info displays.

    4. I have downloaded the OSX update. When I get as far as select destination, all of my drives including Mac HD have exclamations - not appropriate (!!!).

    I am starting to get very nervous here that I have somehow messed up my machine.
  18. macrumors 603


    Software wise or Hardware, it's not hardware and software can be solved.

    I see a lot of problems here on MR regarding Mountain Lion, it is by no means their best OS nor is Lion.

    You don't happen to have a TimeMachine backup, and roll back, be careful with this, I never used TM and I don't know how to solve problems with it and wether you 'Loose' files if you turn back time.
  19. thread starter macrumors member


    Jun 1, 2012
    Qld, Australia
    To be sure... I cleared out all of the caches and restarted again.

    I have quit and uninstalled pathfinder... which is an app I had on my system from pretty much the beginning.

    Yes I have read/write rights for gary(me)

    It still says the MacHD is not an appropriate install disk (is it because I already have 10.8.2 installed?)

    Any other ideas.

    I assume if I do a TM roll back I need to first do a back up of my documents and emails because a roll back will take me to a point that predates any changes to files before that point. My last successful TM update was 7 Dec, which I guess marks the start of my problems.

    Is there any point calling Apple Care with this?
  20. macrumors 603


    Don't call AppleCare, for what, they will probably say to reinstall, well, if you have questions about TimeMachine it won't hurt, as long as it is free.

    I am sorry I can not help you with TimeMachine, I use Carbon Copy Cloner which makes fully bootable disks and I have more control over what to do.

    But, I think that if you were to backup the home folder you will be OK and can go back.
    For instance, you could drag/copy your Home Folder to the external backup and then turn back the clock with TimaMachine.

    You could start looking here on MR how TimeMachine works or start a new thread asking if it will delete files if you do a rollback.

    Only thing I can tell you now is you could for instance make your TimeMachine backup up to date with all your files , then do a reinstall and then do a partial import from TimeMachine(only your Home Folder).
  21. thread starter macrumors member


    Jun 1, 2012
    Qld, Australia
    Okay... many thanks for all your patient support and generosity. I really appreciate your help.

  22. macrumors newbie

    Feb 10, 2013
    The same thing is happening to my computer...i can't access finder or anything that may need to access finder. i tried all the steps in this thread and i can't figure out ANYTHING. nothing works, one of my friends is a mac "Genius" and works for apple so i'll contact him within the next few days or so. but i was just wondering if your problem was ever solved? i am very scared for my poor macbook pro :( . email me at because i only registered on this website so i could respond to the post and honestly never expect myself to return to the site. any help on the conclusion of this matter would be greatly appreciated. Cheers.
  23. macrumors newbie

    Mar 8, 2013
    Reinstall MAC OS

    I had the same problem!
    The only thing I came up with is to reinstall MAC OS.
    Than do all the updates until the problem is gone.

    Good luck to you all!
  24. macrumors newbie


    Jun 25, 2010
    iPhone 4S 64GB
    Finder not responding

    I need help. Finder is not working. It will not relaunch. I cannot quit it and when I go to Force Quit, it just blinks at me and I cannot relaunch it.

    I have downloaded new TotalFinder and Xtrafinder but I cannot find my downloads because I have no Desktop anymore or finder. I cannot access these new applications. When I search for them on Spotlight, Can't open the new applications or even old applications.

    How can I fix my finder?

  25. macrumors 603


    Startup the Mac, input your password in loginscreen and instantly hold the Shift key after hitting Enter, this prevents ant Login Items from loading, does Finder work after you do this?

Share This Page