Finder Problem

Discussion in 'macOS' started by starbuck17, Jul 1, 2006.

  1. starbuck17 macrumors newbie

    Joined:
    Jul 1, 2006
    #1
    I have a really wierd problem with my computer. Ever since yesterday the time, date, airport, bluetooth, battery display and spotlight have been mysteriously missing from the bar in the top right corner of my screen. Every couple of seconds the time and battery power appear on the bar but the immediatly dissappear.

    Im completely baffled by this and i was wondering if any of you guys could give a suggestion of how to fix this.

    Thanks.
     
  2. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #2
    Restart.

    Remove Front Row hack and restart.

    Repair permissions and restart.

    Rename/move/delete the files ~/Library/Preferences/com.apple.systemuiserver.plist and ~/Library/Preferences/ByHost/com.apple.systemuiserver.<gibberish>.plist and then restart.
     
  3. starbuck17 thread starter macrumors newbie

    Joined:
    Jul 1, 2006
    #3
    thank you very much but i can't seem to figure out how to remove Front Row. It isnt in the CoreServices folder in the System folder and i just can't seem to find it. Im sorry about being so new to this I only recently bought my first Mac.

    Thanks
     
  4. starbuck17 thread starter macrumors newbie

    Joined:
    Jul 1, 2006
    #4
    Oh and i couldn't find that file that was supposed to be in the ByHost folder.
     
  5. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #5
    What Mac do you have and which system are you running?
     
  6. starbuck17 thread starter macrumors newbie

    Joined:
    Jul 1, 2006
    #6
    i have a 1.33 GHz iBook G4 with Mac OS X version 10.4.7.
     
  7. mduser63 macrumors 68040

    mduser63

    Joined:
    Nov 9, 2004
    Location:
    Salt Lake City, UT
    #7
    Front Row isn't on your computer unless you downloaded it (illegally) and installed it with a hack. It sounds like you didn't do that, but that's often the cause of this problem, that's why Mitthrawnuruodo suggested it. Anyway, the problem is actually not with Finder, but rather SystemUIServer which is the program/process that handles the menubar icons (among other things).
     
  8. starbuck17 thread starter macrumors newbie

    Joined:
    Jul 1, 2006
    #8
    yes, i didnt think that i even had Front Row on here in the first place. So, how do i fix the SystemUIServer?

    I repaired the permissions and deleted the one file that i could find, but no change so far.
     
  9. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #9
    He-he... if you haven't installed Front Row you shouldn't have a problem with that, no... :)

    Did you restart (right) after deleting the above mentioned file? And, if so, have you tried re-adding the menu items "manually", i.e. go into Systems Preferences and checking for those things you want it.

    Oh, and BTW, does the time and battery menu items still "flash" in every so often...?
     
  10. starbuck17 thread starter macrumors newbie

    Joined:
    Jul 1, 2006
    #10
    yes the battery and time flashed periodically.

    But, i managed to solve the problem myself, all i had to do was an Archive and Install. I didn't feel like going through all the effort to find the root of the problem so i just did a blanket solution.:). Thanks for all the help anyways tho.
     
  11. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #11
    No problem... we'd gotten around to the archive and install option eventually (pretty soon actually ;)), after trying the easy things...

    Glad it worked out... :)
     

Share This Page