Finder Redraw Issues

Discussion in 'macOS' started by telecomm, Dec 13, 2005.

  1. telecomm macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #1
    Is anyone else having finder redraw issues? I get weird behaviour when selecting files whose names are more than one line long. As far as I can recall, this began with 10.4.3, but it may have also been an issue in 10.4.2 (or earlier Tiger versions, I really don't remember).

    It's sort of driving me crazy...
     

    Attached Files:

  2. mj_1903 macrumors 6502a

    mj_1903

    Joined:
    Feb 3, 2003
    Location:
    Sydney, Australia
    #2
    I saw something similar to that back in Tiger beta's (legit copies) but I can't say I have seen it since.
     
  3. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #3
    Is it happening often? Have you repaired permissions recently? I suppose you could remove com.apple.finder.plist and restart but that'll lose your current Finder preferences and may be overkill so try repairing permissions in Activity Monitor first. :)

    FWIW, if you decided to remove the PLIST file form the folder you find it in, keep it on the desktop or somewhere within easy reach so that if it doesn't help, you can put it back where you found it, restart, and have your old settings back. :)
     
  4. telecomm thread starter macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #4
    Yup, I've tried repairing permissions, deleting the finder preferences file, even rerunning the combo updater, all to no avail.

    It does happen consistently, and it's really got me stumped. This started sometime between Panther and the latest Tiger update, but I can't recall exactly when... for some reason I don't think it was a problem with the first Tiger versions, but I'm not really sure about that. I'm on a 12" PB, with the 32 MB GeForce 5200... maybe it's a video driver thing?

    Here's a recent shot... (and despite both pics being Word docs, it's not limited to just Word icons).
     

    Attached Files:

  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    Well, maybe check a new account to see if it happens there too. :)

    If it doesn't you can rule out the GPU driver.
     
  6. telecomm thread starter macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #6
    Tried creating a new account and got this...
     

    Attached Files:

  7. zakatov macrumors 6502a

    zakatov

    Joined:
    Mar 8, 2005
    Location:
    South Florida
    #7
    Long shot, but are you overclocking the vid card or have Q2DExtreme enabled?
     
  8. telecomm thread starter macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #8
    Nope. I was wondering about the Quartz thing (the only info I could find about "finder redraw" issues mentioned 2D Extreme) but I haven't altered any of those settings, and it was supposed to be completely disabled with the last update (not that, as far as I know, it was ever enabled in the first place).
     
  9. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #9
    I saw it for the first time today when the PowerBook was on battery and after I switched from English to Japanese. I sorted the folder by name went back and then forward and it was fine again.
     
  10. telecomm thread starter macrumors 65816

    telecomm

    Joined:
    Nov 30, 2003
    Location:
    Rome
    #10
    Yeah, I've noticed that rearranging things seems to help, but still the problem comes back when I reopen those folders. Oddly enough, I've noticed some items with long filenames don't exhibit this behaviour.

    Anyway, I'm pretty convinced now that it's a driver issue. It's nice to know that I'm not the only one who's experiencing this, though!:eek:
     

Share This Page