Firefox and Full Keyboard Access?

Discussion in 'Mac Apps and Mac App Store' started by mkrishnan, Jan 5, 2005.

  1. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #1
    I found out a couple of months ago, thanks to some lovely people here, that the full keyboard access option in SysPrefs allows me to tab to combo boxes and buttons in Safari.

    However, I don't seem to be able to do this in Firefox, with FKA turned off or on. I can only tab to text boxes, just like in Safari with FKA is turned off.

    I searched high and low for information about this...I found some threads that said that firefox does have this feature (but nothing about how to get it to turn on, or why it's off on my computer), and others which said it doesn't....

    So does anyone know by any chance?

    Is anyone able to tab to buttons, radio buttons or combo boxes in Firefox with the keyboard?
     
  2. nichos macrumors 6502

    nichos

    Joined:
    Jul 17, 2004
    Location:
    Jacksonville, Fl
    #2
    I'm not sure this is what you're looking for, but since no one replied I thought I'd try.
    In the LOCATION bar type: about:config
    there's a value in there called:
    ui.key.menuAccessKey
    and
    ui.key.menuAccessKeyFocuses
    (just search for key, its the last few ones that come up)
    My ui.key.menuAccessKeyFocuses is set to false, and I have a default install. Maybe changing them will work? There is a good explanation of what all of these do at mozdev
    Hope this helps! :eek:

    • Edit: I should mention that the reason this stuff isn't in preferences window, is because sometimes it may break things, so be careful - though I've never had any problems.
     
  3. mkrishnan thread starter Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #3
    Nichos, thanks for the try! :)

    But what that key does is allow you to access the Firefox / File / Edit / View... menus by keyboard. Or, at least, it's supposed to. But I couldn't get it to do even that. Might only work with certain AccessKey integers, and I'm not sure how to get the integer for a complex key stroke like Apple-M.

    I looked around in the accessibility.* keys, but I couldn't find anything. This is really strange, especially because there were definitely threads about this from back when 1.0 came out, but no resolution or even final answer (like they programmed it out because....) And AFAIK, the behavior in MacOS not only ignores the system setting for keyboard accessibility, but also ignores what Firefox does cross-platform, which seems unlike the Firefox team in general....
     
  4. nichos macrumors 6502

    nichos

    Joined:
    Jul 17, 2004
    Location:
    Jacksonville, Fl
    #4
    Hmmm...well sorry if I couldn't help. I'm new to mac anyway :) You may want to try:
    #firefox
    #mozillazine
    both on irc.mozilla.org
    They're the programmings so they should know :D Try #firefox first, but it's not as active as #mozillazine. Good luck!
     
  5. ephramz macrumors member

    Joined:
    Jan 14, 2004
    #5
    No key in preferences

    I figured out how to do it! Thanks to nichos' tip to check over at mozdev it just happened to be one of the first things on the list there:
    accessibility.tabfocus
    Determines which web page elements can gain focus when TAB key is pressed
    * 1 : Text field form controls only
    * 2 : All form controls except text fields
    * 3 : All form controls
    * 4 : Hyperlinks and hyperlinked images
    * 7 : All form controls and hyperlinks

    So just set this to 3 for more Safari-like full accessibility with the tab key. Thanks for starting this thread since this has been bugging me forever. I'm not sure why the default is set to 1, or it's not in the preferences.

    I also was able to fix the annoying thing that the horizontal scroll wheel (found in things like Sidetrack which turns the bottom of trackpads into a scrollwheel) would jump in the history rather than scroll the page. This can be fixed with the mousewheel.horizscroll.withnokey.action which should be set to 0 and the following pref mousewheel.horizscroll.withnokey.numlines should be set to 1, or some other positive small integer.
     
  6. mkrishnan thread starter Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #6
    SWEET! Thanks so much! And Nichos, you showed us the way. :) I saw that item in the config keys but I assumed it was about tabs. :rolleyes:

    And yeah, the scroll fix thing is a must have too, on laptops with sidekick. Actually I got that solution from Alex Harper direct too, and posted it here, but the thread died pretty quickly. There needs to be a running "how to pwn Firefox" thread. :D
     

Share This Page