Firefox and Mail: "Send Link..." function results in broken URLs

Discussion in 'Mac Apps and Mac App Store' started by Argelius, Jan 3, 2006.

  1. Argelius macrumors 6502


    Jun 16, 2005
    (I've searched for other reports of this, but didn't come up with anything...)

    I am running Fx v1.5 on a Mac with OSX 14.3.

    When I want to email the URL of a webpage from Firefox, I click on File=>Send Link... which opens up Mail and pastes the entire URL into the body of the email. Everything looks okay on my end.

    However, when the recipient receives the email, invariably the URL they receive is "broken" (with a seemingly randomly-inserted space) and does not function. This seems to not happen with short URLs (such as

    Here's the troubleshooting I've done:
    [1] If I send the link to myself it works fine when I open it (with Mail).
    [2] If I manually copy the link (from the Address Bar) and paste it into a email message, it still ends up being broken.
    [3] If I use Safari's "send URL" function for the same webpage, it works.
    [4] If I manually copy-and-paste the URL from Safari's address bar, it ends up being broken.
    [5] If I "edit link" in Mail to something like "Check this out" (and then paste the URL into the edit box), it works fine.

    So, evidently, this is some sort of bug in the way Mail handles long URLs. Is this a known issue?

    I realize I could just use Safari, but I like Firefox and all its extensions better....
  2. MisterMe macrumors G4


    Jul 17, 2002
    Never had any trouble sending URLs via Mail. Never heard of any such problems until you.
  3. chkdg8 macrumors 6502

    Oct 24, 2007
    Actually, I'm having problems sending links through Safari and I have everything set up properly. Any thoughts?

    Attached Files:

  4. YokoYoko macrumors newbie

    Oct 8, 2009
    Reviving an old thread to discuss the same problem ...

    Argelius, did you ever resolve this problem?

    Writing today on October 9, 2009, on a G4 running 10.4.11, I've been trying to figure out why my Firefox won't paste a live URL into Mail when I click on "send link". The URL goes in, no problem, but it's not a hyperlink. As with your original problem, short URLs are no problem for recipients, but longer ones break. The fix is to copy the URL and then paste it in via "add hyperlink" (Edit menu), but that's cumbersome.

    Interestingly, this does not happen at all in Safari, which recognizes URLs and hyperlinks them automatically. I've looked in Preferences for a box I had not ticked or whatever, but there seems to be no way to activate this functionality ... which seems very odd.
  5. Argelius thread starter macrumors 6502


    Jun 16, 2005
    Hi There,

    I did solve my problem (i.e. I'm no longer having the broken link problem), but unfortunately, at this point I have no idea what it is that I did (if anything) to fix the problem.

    You might try this extension:

    (it will share pages to a bunch of different sites, but I've got my "Share" menu pared down to just facebook and email...)


Share This Page