Firefox and printing headers

Discussion in 'Mac Apps and Mac App Store' started by petteri, Mar 3, 2007.

  1. petteri macrumors member

    Joined:
    Aug 4, 2006
    #1
    Hi,

    I'm not sure if this is a Firefox or printer driver issue but I cannot seem to turn
    OFF printing the header and footer when printing web pages from Firefox. I can't seem to do this with Safari either, but I use Firefox as my browser. Under File -> Page Setup there are only settings for :

    [​IMG]


    I'm using an unsupported printer, a Canon MP730 running with a driver from PrintFab. I'm guessing that might be the problem but could someone confirm this? Thanks!


    EDIT:SOLVED!!

    enter in about:config in the address bar
    type in header into the filter bar
    delete any info these value settings
    type in footer into the filter bar
    again delete the values (NOT the entire line!)

    now you should be able to print web pages minus the header and footer!
     
  2. Benjamin macrumors 6502a

    Benjamin

    Joined:
    Oct 27, 2003
    Location:
    Portland, OR
    #2
    well... for future reference i believe if you use the print command and select the third pull down to the application you can get those settings in either browser. That should get you the same results.
     

    Attached Files:

  3. petteri thread starter macrumors member

    Joined:
    Aug 4, 2006
    #3
    I don't seem to have that option:

    [​IMG]

    EDIT: I can do this with Safari, but not Firefox.
     
  4. artybear macrumors newbie

    Joined:
    Dec 9, 2007
    #4
    Header and Footer option gets broken

    I have the same problem where the "Firefox Settings" in the print menu don't show up. My housemate has a similar system with the same OS version (10.5.1) and the same Firefox version (2.0.0.1.1), and he does not experience this problem.

    I tried uninstalling all of my add-ons (extensions and themes), and that did not help.

    I then downloaded a fresh copy of firefox and ran it from its disk image in stead of dragging it to my Applications folder. Behold! It has the print setting!

    BUT... that's at my default homepage (google). It continues to have that header/footer setting available until I navigate to www.wordpress.com. Thereafter, even at the other websites, the setting doesn't show up. It's broken.

    Back to my housemate who has nearly the same system: he goes to wordpress and still has the setting. So, I think something else is breaking it, but I don't know what.

    This is pretty frustrating. I change the header/footer print options quite frequently.
     

Share This Page