Firefox change open with for .pls files?

Discussion in 'Mac Basics and Help' started by dragon2611, Nov 6, 2006.

  1. dragon2611 macrumors regular

    Sep 19, 2004
    How do i change the Open with association in firefox for a .pls or .m4u file.

    It deafults to Itunes which i don't wish to use becuase it always saves the damn thing in the libary and unlike the windows firefox there doesn't seem to be an option on the dropdown to change it :mad:

    I want to have it so whenever i click a link with M4U or a PLS file it just opens it up in either quicktime or vlc (Ive setup my mac mini as a media server, now on my pc i can get the play link to open my prefered media player and start streaming my choosen tracks on my mac i seem to only be able to get firefox to open the playlist files with itunes)
  2. bobber205 macrumors 68020


    Nov 15, 2005
  3. dragon2611 thread starter macrumors regular

    Sep 19, 2004
    i goto prefs but theres no downloads tab just a downloads ection and theres no edit actions option.

    I also tryed MIME types under content but it just shows PNG and TIFF and says to open with quicktime player... i can change those but it doesnt seem to have any options for adding other types.

    Sorry i should of said using firefox 2.0 think they moved some prefs around
  4. bousozoku Moderator emeritus

    Jun 25, 2002
    Gone but not forgotten.
    Preferences->Content->File Types->Manage...

    Attached Files:

  5. dragon2611 thread starter macrumors regular

    Sep 19, 2004
    I've been in there and theres .png and .tiff which is set to open with quicktime...

    I could change those if i wanted to... but there doesnt seem to be any option to create a new one for .pls and .m4u files :eek: :confused:


    Never mind its me being stupid, didn't relise you had to tick always perform this action checkbox the first time you download and click open with, then it will show up in the manage content dialouge and allow you to change what it opens with.
  6. redog macrumors newbie

    Jan 14, 2008
    bump...bump...still an issue in version any solutions yet?

Share This Page