Firefox closes tabs -resume doesn't work

Discussion in 'Mac OS X Lion (10.7)' started by Jamooche, Jul 28, 2011.

  1. macrumors regular

    Jul 23, 2011
    The OSX Lion resume function doesn't work for me in Firefox. I'm pretty sure it was working before tonight, but now even with the option to warn when closing multiple tabs checked, if I quit Firefox and reopen, it only opens to my home page. I'm not sure what happened.

    I think I'm going to be a Safari convert. Firefox has no gesture support and doesn't resume multiple tabs or even the last page you were on. Yes, I know you can click on the History>Restore Previous Session, but this is an unnecessary task in OSX Lion.

    Anyone else having this problem? Any fixes?
  2. macrumors demi-god


    Oct 9, 2005
    I haven't used Firefox on the Mac in a while (I prefer Safari) but I think apps have to specifically support the resume feature in Lion. Right?
    Perhaps there's a preference in Firefox to automatically restore previous sessions?
  3. macrumors member

    Apr 27, 2011
    Firefox has add on's that can save your tab history. I forget which add on I used but their are many more and you'd best be searching for the one you like for your needs.

    I've begun do switch over to Safari after just two days of running Lion. I like the gestures and full screen mode. I use BetterTouchTools to activate Launchpad with my magic mouse and will be adding more for a better browsing experience.

    Overall Safari seems faster than Firefox for me. Flash works okay now that I've fixed the settings. I hated the idea of Safari before and was exclusive to Firefox for years. Now I suddenly love it, but still getting used to all the x buttons on opposite sides than Firefox. No biggie though. Just takes getting used to. I already seem to have adjusted to the scrolling really well. It 'feels' natural when I just visualize pushing the screen around.
  4. thread starter macrumors regular

    Jul 23, 2011
    I'm actually a Windows 7 PC convert with the new MacBook Airs that just came out. Getting a desktop Mini or Pro next. It's amazing how quickly (when you have the right mindset) you can switch over to a new style. I'm on my Dell work computer and just tried doing a keyboard shortcut and hit the Alt key (where the Command key is on the Mac) instead of Ctrl.

    I switched over to Firefox as default browser last night and that's when I noticed all these things were not working. The one thing I don't like about Safari is that you need to go to 3 different places to clear cache, history, and cookies. Firefox puts everything in a neat list where you can clear all in one go. I also created a css style sheet to keep a default zoom. I've only found one website where it slightly changes the formatting. I love the double tap to quickly zoom in. Great feature.
  5. DewGuy1999, Jul 29, 2011
    Last edited: Jul 29, 2011

    macrumors 68040


    Jan 25, 2009
    I don't know how this works with Lion since I haven't upgraded yet, but Firefox 4 would warn you when you quit with tabs open and then reopen them on the next launch. They changed that in Firefox 5, now if you want to restore your last session, just go to the History menu and select Restore Previous Session. YMMV with Lion.

    I liked it better the old way because I never remember to do it the new way.

    Edit: After I posted the above I began to wonder if there was something else to set since Firefox has so many preferences, some of them hidden, and I found this:

    Configuring session restore

    By default, when Firefox starts, a single window is opened, displaying your specified home page. If you wish, you can configure Firefox to open all windows and tabs from your previous session:

    On the menu bar, click on the Firefox menu and select Preferences....
    Select the General panel.
    From the When Firefox starts drop-down, select Show my windows and tabs from last time.
    Close the Preferences window.

  6. thread starter macrumors regular

    Jul 23, 2011

    Thanks...I will definitely use that feature. That setting panel must override the Lion resume tabs function. However, it still doesn't explain why when I have "warn me when closing multiple tabs" checked that it closes without warning.
  7. macrumors 68040


    Jan 25, 2009
    Doesn't work for me under Snow Leopard 10.6.8 either. Methinks that someone at Firefox forgot to reword or remove that setting for version 5...or it's a bug.
  8. macrumors newbie

    Oct 25, 2012

Share This Page