Firefox distorting text??

Discussion in 'Mac Basics and Help' started by purdueblondie, Feb 22, 2006.

  1. purdueblondie macrumors newbie

    Joined:
    Feb 22, 2006
    #1
    I just recently downloaded Firefox for my mac. However, when I write emails (I use Gmail) the text starts to get garbled by wherever the curser is. It's like I'm typing too fast for it and it gets all messed up and I don't know what I'm typing anymore. I also tried other programs like Camino and it does the same thing. Typing is completely fine in Safari. Anyone know whats up or how I can fix this problem so I can use Firefox?

    Thanks!
     
  2. iBlue macrumors Core

    iBlue

    Joined:
    Mar 17, 2005
    Location:
    London, England
    #2
    that's weird, i've heard of the typing lag with Camino, which is because of some issue with the way it draws text, but never heard of it with firefox.

    have you dumped your browser cache and closed firefox and seen if it reacts the same way?

    out of curiosity, are you using rich text format in gmail too? (may cause a small hiccup)
     
  3. stridey macrumors 65816

    stridey

    Joined:
    Jan 21, 2005
    Location:
    Massachusetts, Connecticut
    #3
    <side>Typing is much faster in Camino than it used to be. :)</side
     
  4. iBlue macrumors Core

    iBlue

    Joined:
    Mar 17, 2005
    Location:
    London, England
    #4
    oooh good! that was my only real complaint about camino, the text lagging thing. :) thanks, glad to hear it.
     
  5. iBlue macrumors Core

    iBlue

    Joined:
    Mar 17, 2005
    Location:
    London, England
    #5
  6. purdueblondie thread starter macrumors newbie

    Joined:
    Feb 22, 2006
    #6
    Alright. Not looking good. I cleared the cache for Firefox. I also tried using the javaEmbeddingPlugin and followed those directions. No luck. The only thing i found to make it go away is when I switch Gmail from standard to basic html. However, when I go to basic html, its just like it is in Safari where I can't use the new Gmail Chat feature or Different font capabilities. Grr.

    I hope I'm not doing anything wrong?

    My bf uses firefox on his mac mini and has no problems. I have a powerbook. I don't see how mine is messing up and his isn't...
     
  7. stridey macrumors 65816

    stridey

    Joined:
    Jan 21, 2005
    Location:
    Massachusetts, Connecticut
    #7
    Here's a weird thought. What if Gecko (the core running both Firefox and Camino, but not Safari) doesn't respect the system preference "Ignore accidental trackpad input", but Safari does? I don't even know if that's technically possible, but if it were, it might explain the problem. If your hand position makes your fingers brush the trackpad while you type, it could be clicking accidentally. It would certainly explain the behavior.

    purdueblondie, can you go to System Preferences->Keyboard & Mouse->Trackpad and see if that checkbox (""Ignore accidental trackpad input") and the "Clicking" checkbox are checked? Just on the off-chance...
     
  8. iBlue macrumors Core

    iBlue

    Joined:
    Mar 17, 2005
    Location:
    London, England
    #8
    does it do it anywhere other than Gmail?
     
  9. purdueblondie thread starter macrumors newbie

    Joined:
    Feb 22, 2006
    #9
    Yeah, my preferences ignore accidental trackpad movements.

    It actually does it other places than just Gmail. In sites like Foxnews.com or on Gmail before I'd even sign in, the text is almost smooshed together in plenty of areas. I believe it isn't just textboxes or anything specific like that. It's just more obtrusive when trying to write emails and the curser is lagging behind the letters i'm writing.
     
  10. funkychunkz macrumors 6502a

    funkychunkz

    Joined:
    Jun 1, 2005
    Location:
    Ottawa, Canada
    #10
    Try seeing if font smoothing is the same on both computers. I know while scroling source code in FF, things can get weird (text blocks go over others, some scroll, others don't).
     
  11. purdueblondie thread starter macrumors newbie

    Joined:
    Feb 22, 2006
    #11
    So after a while i found a quick and easy fix. It's not a complete fix, but it really doesn't bother anything. In FF preferences, for fonts & colors, in advanced, UNCHECK "allow pages to chose their own fonts, instead of my selections above". That makes all text go to what you chose them to be which terminates any curser problems and text scrunching. Thanks for your help all.:)
     

Share This Page