Firefox: Tab stop on every field...

Discussion in 'Mac Apps and Mac App Store' started by yg17, Aug 3, 2006.

  1. yg17 macrumors G5

    yg17

    Joined:
    Aug 1, 2004
    Location:
    St. Louis, MO
    #1
    One thing that bugs me, is when tabbing through forms, Firefox will skip buttons, checkboxes, dropdowns. Basically, anything that isn't text input. Is there any way to change this so it stops at every field? Thanks
     
  2. panoz7 macrumors 6502a

    panoz7

    Joined:
    Nov 21, 2005
    Location:
    Raleigh, NC
    #2
  3. keltoid macrumors newbie

    Joined:
    Jul 18, 2008
    #3
    Old question, but someone else may find their way here looking for info:

    Just found this elsewhere:

    By default, on a Mac in Firefox, tab moves from one form element to another—except it will skip radio buttons, checkboxes and drop-down select boxes. I have suffered in silence since I started using the Mac. I finally found out that this too can be remedied. Hooray!

    There is an actual setting in the Mac OS that produces this behavior. To change this so that tab treats all form elements with equality go to: System Preferences -> Keyboard and Mouse and select the tab Keyboard Shortcuts. On the bottom you will see a setting for “Full Keyboard Access”. Just set it to All Controls. This setting will take effect right away, no need to restart Firefox.
     
  4. G-Com macrumors regular

    Joined:
    May 21, 2008
    Location:
    North of The 'Nati
  5. pixeler macrumors newbie

    Joined:
    Feb 13, 2009
    #5
    Sorry to revive an old thread, but this is very helpful! But what's the downside of activating this? Does this produce any unwanted behavior in other apps?
     
  6. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #6
    I've never run into any. I always change this setting on a new install within the first week. Not sure why Apple doesn't default it to this.
     

Share This Page