Firefox: Why does it phone home CONSTANTLY?

Discussion in 'Mac Apps and Mac App Store' started by Mr. Monsieur, Jan 23, 2005.

  1. Mr. Monsieur macrumors 6502

    Joined:
    Apr 21, 2004
    #1
    hello folks...i already posted this question, but didn't really receive an answer that put my mind at rest. Essentially,every time I use Firefox, Little Snitch (a program I have that keeps watch over my ports) blows the whistle on Firefox, noting that the program wants to connect to the Internet for some reason (this never happens with Safari or IE)(this is a constant situation, that is, Firefox is not just looking for updates, but wants access continuously-for every single page i go to)...these alerts usually inform me that one of my programs is trying to send information out of my computer...the only way I can use Firefox is by allowing it unlimited access to my computer...which is both annoying and potentially foolish...I'd like to use Firefox, but until I understand why it's doing this, I probably won't...
     
  2. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #2
    Do you have "Link Prefetching" turned on? (Cache Preferences)
     
  3. Mr. Monsieur thread starter macrumors 6502

    Joined:
    Apr 21, 2004
    #3
    hey bear,

    thanks for your response...in answer to your question, no, i don't have link prefetching turned off...nor can i find it in firefox preferences as you suggest...where is it? i did find a link at mozilla that mentions that the mozilla 1.3 browser allows the prefetching to be turned off, but nothing about this in firefox...
     
  4. Mechcozmo macrumors 603

    Mechcozmo

    Joined:
    Jul 17, 2004
    #4
    Could it be that FireFox is an internet browser?

    It also checks for updates pretty often. Something held over from beta releases I think. You can change that....
     
  5. panphage macrumors 6502

    Joined:
    Jul 1, 2003
    #5
    The question I'd have is why IE and Safari DON'T send out information for every page you visit. A browser must send a request to a web server for every single page you try to view. The server responds with the page. Maybe IE and Safari are sneakier about it than firefox?
     
  6. Bozola macrumors regular

    Joined:
    Jul 18, 2002
    Location:
    So close to Redmond, I can smell it!
    #6
    Just delete all 'live feed' bookmarks..
    They look like they have tilted orange airport signals next to them.
     
  7. Mr. Monsieur thread starter macrumors 6502

    Joined:
    Apr 21, 2004
    #7
    thanks bozola...could you provide me with a road map to do this? i've been poking through the mozilla search engine and help topics, but haven't found this...i also went into "bookmarks," but didn't see anything that looks the way you describe...thanks again...
     
  8. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #8
    This link shows you what the icon looks like.

    http://www.mozilla.org/products/firefox/live-bookmarks.html

    You might not have any though....What I would recommend is perhaps deleting all the bookmarks that you didn't create, unless you actually use them. But you should be able to see if they're live pretty easily.
     
  9. Bozola macrumors regular

    Joined:
    Jul 18, 2002
    Location:
    So close to Redmond, I can smell it!
    #9

    Attached Files:

  10. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #10
    Firefox > Preferences. Click Advanced icon and review your software update settings.

    Frankly, I would leave them on and think you are being too anal. Nothing like not finding out about a patch in time :rolleyes: The checks are in place to help you.

    PS. Its not that foolish since any intrusions can only come IN on ports you have open...outbound requests won't do any harm.
     

Share This Page