Flaky D2X install....

Discussion in 'Games' started by Lord Blackadder, Mar 14, 2007.

  1. Lord Blackadder macrumors G5

    Lord Blackadder

    Joined:
    May 7, 2004
    Location:
    Sod off
    #1
    A little distraction fromm the console wars here...

    I recently reinstalled Diablo II LoD on the G4 in my sig, getting back into the game after a couple years off and trying to run through the game with a Meleemancer (a necromancer who fights melee, I'm trying the tougher variant with a two-handed weapon. Fun!).

    Anyway, I installed Diablo II and a new copy of LoD (lost the old disc). The game was installed on my second (non-boot) drive, and my original install of the game was still on my boot drive. Game performance was awful; it took 20 seconds of black screen before the game launched, and every time I got to a waypoint or boss the game would either stutter badly, hang for up to 2 minutes, or crash. When I killed Diablo the first time the game hung for almost 5 minutes - I thought it had crashed but luckily I left the machine (in disgust) and it snapped out of it so I could save.

    I subsequently deleted the original install from my boot drive and that eliminated the long loading time, but I still crash about once per gaming session, which is unacceptable. I just noticed I'm running version 1.10, so I'm going to log into battle.net and get the 1.11 patch tonight.

    My Mac should ba able to handle the game no sweat, so something's buggy. Has anyone else experienced this? If the patch doesn't fix things I may just set aside my saved characters folder and reinstall.
     
  2. MRU macrumors demi-god

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Ireland
  3. Lord Blackadder thread starter macrumors G5

    Lord Blackadder

    Joined:
    May 7, 2004
    Location:
    Sod off
    #3
    You're missing out then. ;)

    It's a pretty good game for being 8 years old (!) this year.
     

Share This Page