Foreign Characters in Filenames

Discussion in 'Mac Apps and Mac App Store' started by powerdave, Oct 25, 2004.

  1. powerdave macrumors regular

    Joined:
    Apr 24, 2004
    Location:
    Hamburg
    #1
    Hi,
    I wanted to copy over some Swedish files from a friend's external harddrive, but I have a problem. The original files have swedish characters in the filenames, and when I look at them on the Mac, the filename shows right up as far as the foreign character, adds a "?" and leaves out the rest, including the file extension.

    So aswell as not being able to view the full filenames, I can't open them.. the lack of a file extension seems associate them as "Unix Executable Files".

    Apart from going back to the original files in Windows and taking out the Swedish characters (which would be too tedious), how can I transfer these files over?
     
  2. bousozoku Moderator emeritus

    Joined:
    Jun 25, 2002
    Location:
    Gone but not forgotten.
    #2
    Have you taken out the Swedish language localisations?

    Perhaps, if you enable the Swedish keyboard and select Swedish as the main language while pulling over the files, it will change the outcome.
     
  3. powerdave thread starter macrumors regular

    Joined:
    Apr 24, 2004
    Location:
    Hamburg
    #3
    While I had the drive connected, I changed the first language to Swedish in the System Prefs alright. All my menus etc. changed, as expected, but I noticed no change in the filenames. Maybe I should have disconnected and reconnected the drive? ..I'll try that tomorrow.

    Edit: I hadn't changed the Keyboard settings- I just found the option now. I'll try that tomorrow too. Thanks for the help!
     

Share This Page