Frequent Wireless Disconnects

Discussion in 'macOS' started by rcm3, Mar 30, 2007.

  1. rcm3 macrumors member

    Sep 19, 2006

    I'm at a complete loss. All the PCs on my wireless network (WPA security) are consistently connecting without issues. They experience none of the problems that I have with my MBP.

    When I turn my computer on or wake it up, I am 'connected' or so it says, but I am never able to reach the internet until I (wait a long, seemingly random amount of time or) disable my wireless adapter, re-enable it, and select my wireless network.

    I did not experience this problem prior to:

    -Trying out a new AirPort Extreme, returning it and going back to my old G router. The AirPort worked great for this computer, but it had problems with the PCs and the xbox 360 (yes.. i know there is a workaround now...)

    -Going to a WPA secure network. Prior to switching back from the AirPort I just ran an unsecured, non-broadcasted network.

    Any advice would be greatly appreciated!
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    So your current router isn't an AirPort then?... Can you run with WEP or even better, can you run with a disabled SSID broadcast and MAC address filtering? It's arguably more secure and your Mac shouldn't have any troubles with it. There seems to be a bit of a recurring problem with Intel Mac laptops and WPA... Hopefully Apple gets it sorted soon. :)
  3. edfred macrumors newbie

    Sep 13, 2006
    Problem Staying Connected

    Has anyone else had a problem or noticed that their new Airport Extreme will not stay connected?

    I have had BellSouth Check my entire phone system and have changed everything trying to fix this problem. I even exchanged my my Airport Extreme for a new one, but continue to have disconnects on the wireless to both my Laptop and and My iMac.

    I have installed th new updates hoping that this would fix the problem, but it hasn't.:( :confused:

    Contacted apple and they say that the problem is not theirs! ????? :confused:

    Even re-connected my old router, and "DID NOT HAVE THE PROBLEM"

    Not very happy with the New Extreme.:mad:

  4. edfred macrumors newbie

    Sep 13, 2006
    Well well,

    I finally got my problem fixed with the new Airport Extreme. Apple once again proved that their product was not at fault.:) :)

    AT&T (Aka Bellsouth) finally figured out that the problem was at their end.

    My problem no longer exists, and Airport extreme is working great.

    Sorry Apple for doubting

  5. alienprdkt macrumors newbie

    Oct 4, 2008
    For linksys routers I turned SSID Broadcast to disable ( When wireless clients survey the local area for wireless networks to associate with, they will detect the SSID broadcast by the Router. To broadcast the Router SSID, keep the default setting, Enable. )

    Without your SSID being broadcasted I also disabled my security encryption for my wireless (bout 300 feet) figured that if my SSID doesn't show up then i should be ok within my neighborhood, and besides this is the only way that i have found to keep a connection between my mac osX Leopard and my Linksys wireless router.
  6. rcm3 thread starter macrumors member

    Sep 19, 2006
    Thread resurrection eh?

    I finally threw out my old router and picked up a Airport extreme. When I tried it before, Apple/MS had some serious issues to work out. But now that it's been out for more than a year everything works like a charm.

    The apple router speeds up and troubleshoots every aspect of my wireless network drama-free.

    So there's the solution. Tired of your D-link/Linksys/whatever...? Scour craigslist for a few days and find yourself a cheap airport extreme base station.
  7. austinchuck macrumors newbie

    Dec 5, 2008
    I have seen some bad advice on internet forums but this takes the cake. Disabling the SSID broadcast does not compensate in any way for turning off encryption. If someone is sniffing traffic, turning off SSID broadcast does nothing.

Share This Page