FTP Help Needed...Before I Go Insane

Discussion in 'Mac Basics and Help' started by junebug1, Jan 24, 2007.

  1. junebug1 macrumors regular

    Joined:
    Jan 24, 2007
    #1
    Okay so my girlfriend just moved to DC and I am in Ohio. I want her to be able to access my Powerbook from her PC. I have tried to setup an FTP but I'm pretty sure I am not doing something correctly. I am using a Linksys WRT54G Wireless Router and so is she. So obviously my Internal IP is something like 192.168.1.10x and I went to whatismyip.com to get my External IP (24.239.xxx.xx). I just don't know what to make sure I have setup from here. This is what I have done so far but nothing is working.

    1. Turned on FTP Sharing in System Preferences (tells me that users can connect using ftp://192.168.1.10x)
    2. Went into router settings under Applications and Gaming to make sure that Port 21 was enabled for my 192.168.1.10x
    3. Had her try to connect using IE and Firefox by typing in ftp://192.168.1.10x and when that didn't work she also tried ftp://24.239.xxx.xx)

    Nothing happens. No Login prompt. Just can't connect. Can someone please help me in setting this up correctly. Thanks in advance.
     
  2. MacsRgr8 macrumors 604

    MacsRgr8

    Joined:
    Sep 8, 2002
    Location:
    The Netherlands
    #2
    Firts of all, your girlfriend must try to connect to your "real" internet address: 24.239.xxx.xx (your internal IP address 192.168.x.x can only be reached by others on your own home-LAN, i.e. "behind" the router).

    You mentioned that port 21 was "enabled" for your internal IP address (192.168.x.x), but is the router also configured to "forward" port 21 to your internal IP address?
    Also, you are sure no Firewall is blocking port 21 (check on your Mac and router) ?

    If you really want to make sure that all ports lead to your internal IP address, then you could setup the router to have a "default server" configured, to which ALL connections go.
    Doing that makes it easy to test if maybe another protocol will work.
     
  3. aristobrat macrumors G4

    Joined:
    Oct 14, 2005
    #3
    From a browser on your Mac, I'd try ftp://192.168.1.10x and make sure it connects. If it doesn't, I wouldn't go any further until that's fixed.

    Then (also from your Mac), I'd try to ftp://24.xxx.xxx.xxx and make sure that worked. If it doesn't, but the first test worked, I'd check the port forwarding in the router.

    If both of those work, and your GF still can't connect, one thing to consider is that your Internet provider may have blocked incoming FTP requests. The main cable modem provider out here does that for residential accounts.
     
  4. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #4
    FTP uses two ports, 20 and 21 in most cases. So make sure both are forwarded appropriately. Don't use Passive mode when connecting.

    Also, have her try a real FTP client such as Filezilla, it may give a better error message to the real problem.
     
  5. junebug1 thread starter macrumors regular

    Joined:
    Jan 24, 2007
    #5
    Wow thanks for the quick responses. Okay so far I can connect to myself using ftp://192.168.1.10x but nothing happens when using ftp://24.xxx.xxx.xx . My computer most definitely has no firewall running and on the router under my firewall tab its disabled. I have made sure to enable both ports 20 and 21 under my Port Range Forward tab but MacsRgr8 asked if my router was also configured to "forward" port 21 to your internal IP address. I don't see any options to select that when port 21 is triggered to forward it to 24.xxx.xxx.xx. How exactly do I do this because that may be my problem. Thanks again for the speedy replies. You guys are great.
     
  6. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #6
    Keep in mind
    Your internal IP is 192.168.1.10x - this can only be seen from inside your network.
    Your external IP is 24.xxx.xxx.xxx - this is the one that everyone on the interweb will use

    When you configure port forwarding on your router (under Applications & Gaming), you decide the port range and the INTERNAL IP to forward to, make sure you have clicked the enable button and TCP protocol (FTP doesn't use UDP). From what I have read, it sounds that you did this correctly. If you can connect using your internal IP but not your external, it sounds like your ISP is blocking it.

    Take a screenshot of your router port forwarding screen and attach it here so we can verify its all good. Don't worry about exposing your internal IP address, nobody can access that.
     
  7. junebug1 thread starter macrumors regular

    Joined:
    Jan 24, 2007
  8. junebug1 thread starter macrumors regular

    Joined:
    Jan 24, 2007
    #8
    also i really doubt my isp is blocking this because a few of my friends have ftps setup on their pcs through the same isp.
     
  9. jeremy.king macrumors 603

    jeremy.king

    Joined:
    Jul 23, 2002
    Location:
    Fuquay Varina, NC
    #9
    I can't really read the JPG, but do I see you forwarding port 21 twice (to different machines - FTPXBox maybe)? That would definitely be an issue.
     
  10. aristobrat macrumors G4

    Joined:
    Oct 14, 2005

Share This Page