FTP issues

Discussion in 'Mac Help/Tips' started by cleo, Sep 10, 2002.

  1. cleo macrumors 65816

    cleo

    Joined:
    Jan 21, 2002
    Location:
    Tampa Bay Area, FL, USA
    #1
    I uploaded a bunch of files and directories to my ftp server earlier today. Then I reorganized the files and now want to delete a directory that is no longer used. However, I get an error saying that the directory is not empty, even though it most certainly IS empty. I've chmod'ed 777, and for crying out loud, it's *my* folder! How do I get rid of it?
     
  2. szark macrumors 68030

    szark

    Joined:
    May 14, 2002
    Location:
    Arid-Zone-A
    #2
    It sounds like you may have some hidden files in that directory.

    If you are using a graphical FTP client, see if there is an option for viewing hidden files.

    If you are using command line FTP through Terminal, "cd" into the directory and type "ls -a" to see any hidden files.

    Can't think of any other reason why that would be happening...
     
  3. cleo thread starter macrumors 65816

    cleo

    Joined:
    Jan 21, 2002
    Location:
    Tampa Bay Area, FL, USA
    #3
    Brilliant.

    Thanks tons. My graphical app wasn't showing anything even when I turned on hidden files, but I found it in a snap through terminal.
     
  4. mmmdreg macrumors 65816

    mmmdreg

    Joined:
    Apr 14, 2002
    Location:
    Sydney, Australia
    #4
    yah that happened to me once as well..pain until I figured it out...
     
  5. szark macrumors 68030

    szark

    Joined:
    May 14, 2002
    Location:
    Arid-Zone-A
    #5
    Re: Brilliant.

    Glad I could help!

    For the graphical app, you may have to set the destination machine type to UNIX (assuming you can) in order to see them.
     

Share This Page