FTP / Sharing Problems. Need to share 8GB data over t'internet

Discussion in 'OS X Mountain Lion (10.8)' started by stevegreen22, Aug 7, 2012.

  1. macrumors newbie

    Aug 7, 2012
    Hi all,

    I'm having a few issues and hoping you may be able to help.

    I need to share 8GB or so worth of data for someone at the other end (Asia) to download onto their mac.

    I've tried setting up an FTP and DNS account but that seems to have failed, the DNS resolves to be the correct IP Address but then when trying to connect directly to IP I get no joy either.

    I then considered trying tos et up Web Sharing and quickly found how to enable that on ML but I still cannot connect to the machine that hosts the files.

    I've followed the guides that I can find but at a loss.

    The user account has sharing privileges set up and in place inc ftp. (I think it's now changed to afp?)

    Can anyone suggest anything I may have done wrong?
    I've installed SMBup for use with the APTV, have tried to connect with it and without it being activated

    If there's another option for sharing the data then that'd be great but now I've started I'd like to get this working as it'd solve a lot of other issues with sharing

    DropBox etc isn't considered an option due to the restrictions on file size.

    many thanks in advance
  2. macrumors 68030

    Feb 26, 2011
    Cincinnati, OH
    How is your bandwidth? I would consider uploading to Amazon S3 or another cloud service. FTP is now command line only in ML unless you are using another purchased server, and even then I would use SFTP, since it is more secure. Perhaps overnight the data?
  3. thread starter macrumors newbie

    Aug 7, 2012

    Thanks for the reply.

    Bandwidth is reasonable, nothing special though.

    The files are all approx 1GB in size each.

    S3 looks like a great service but I need it to be free really.

    I would like to set up this share as it would make things easier in future.

    Filezilla would be preference for ftp. Although I expected to eb able to use Go > Connect To Server and then see a mini finder window?
  4. macrumors 68030

    Feb 26, 2011
    Cincinnati, OH
    I would tackle the DNS issue first, as you know you won't be able to get things working if you can't connect.

    Second, turn on File Sharing, Select the folder to share. Add a User and then the other user should be able to connect.
    What errors are you getting?


    Also what other systems are in the way? Other firewalls in play here?
  5. macrumors 65816

    Mar 13, 2012
    It sounds like this is the issue since using the IP didn't work for him either.

    If you're using pNAT or a Firewall, you'll need to forward the proper ports (21 + data ports) to your internal IP.
  6. thread starter macrumors newbie

    Aug 7, 2012
    no firewalls except the standard setup in ML.

    Router has been configured to allow port 21


    ...I thought...I had it right...

    I think I've screwed up the port forwarding as well. Although I thought for this I's jsut need to create a new service for tcp/udp and set range of ports to 21?
  7. macrumors 68030

    Feb 26, 2011
    Cincinnati, OH
    Check the system log for the actual error regarding permissions, it might shed more light on it.

Share This Page