FTP upload very slow

Discussion in 'Mac OS X Server, Xserve, and Networking' started by bfeely, Jan 29, 2010.

  1. macrumors newbie

    Joined:
    Jan 29, 2010
    #1
    Hi

    Recently I moved into an new office. The office is part of a block of 20 offices connected to the same broadband. My mac is connected via an ethernet cable to I think a Lan box in the wall.

    I am experiencing a problem with uploading files. It is very slow at 30kbs. I normally use yousendit, but it's too slow. I have tried uploading using Fetch, same problem. I thought it might be the broadband connection, but now I don't think it is. I have done a speed test at speedtest.net. My download is 3.81MBs and my upload is around 0.31MBs. I tried using a USB modem (a dongle) with o2 mobile broadband, same problem.

    My download speed is fine, i.e. files sent by my clients are downloaded at an efficiently fast speed. Uploading is mission impossible.

    When I send files using yousendit on their .com website, I do get 2mbs a minute, not great but at least credible.

    I'm thinking that there are settings in network that need changing but I don't know what. My firewall is on 'allow all incoming connections'. I have a fixed IP address.

    My ISP can't advise me. Can anyone help?

    10.5.8
    Intel mac

    B
     
  2. macrumors member

    mcprobie

    Joined:
    Nov 16, 2009
    Location:
    Paradise Corrupt
    #2
    0.31 MB/s = 310 Kb/s

    Your upload speed is not lying I think ... Calculate it like this, but be sure to make a distinction between KB and Kb

    1Mb/s = 1024Kb/s
    1KB/s = 8kb/s

    310/8 Kb/s = 39 KB/s

    So make sure you notice the difference ...

    I think your ISP can help ... But probably they will need to either upgrade their backbone or de-cap their modem :)
     
  3. thread starter macrumors newbie

    Joined:
    Jan 29, 2010
    #3
    FTP upload slow

    I don't think it is my ISP's problem. I am sure from my efforts with different FTP programs and also testing my upload speeds using a wireless USB modem with o2i.e. not using the office broadband, that the problem lies in my computer's Network settings. Well that's what I think.

    Any other suggestions?

    B
     

Share This Page