G3 iMac hard drive spins up/down constantly in sleep mode

Discussion in 'PowerPC Macs' started by Heb1228, Aug 21, 2009.

  1. macrumors 68020

    Heb1228

    Joined:
    Feb 3, 2004
    Location:
    Virginia Beach, VA
    #1
    I'm hoping someone has a solution to this issue. It's a new one for this iMac. I've had it probably 4 years now and it's never had the problem before. I put it on Craig's list so wanted to wipe the drive and figure I'd play around with OS 9 a little just for fun.

    While in OS 9 it prompted me to upgrade the firmware on the DVD-ROM drive. I thought that sounded like a good idea since it makes some terrible noises when a disc is in... anyway, I did the firmware upgrade and everything went fine. That's the only real change I can think of that might have contributed to this new issue.

    Anyway, after that I put 10.3 on it again (I had 10.4 on it before) and it wouldn't sleep correctly. Everything looks like its going to sleep ok, then the hard drive spins up, then back down, over and over again endlessly.

    I tried an erase and install of 10.3 again but it didn't solve the problem. Did the firmware upgrade screw the computer? Can you think of anything else that might be causing it? I've checked the obvious culprits, energy saver and "wake on ring" type stuff. Nothing seems to help.

    Here's a similar problem discussed at Apple support, but no answer is given there that seems to help in my instance. http://discussions.apple.com/thread.jspa?threadID=882140
     
  2. macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #2
    you need a new hard drive. Easier to do than it seems.

    Your iMac cannot be only four years old. The last iMacs sold were I believe in 2002. Your hard drive is seven years old, at least.
     
  3. thread starter macrumors 68020

    Heb1228

    Joined:
    Feb 3, 2004
    Location:
    Virginia Beach, VA
    #3
    I've had it for four... got it on ebay, replaced the HDD, added RAM. The drive is older than than, though, I had it in a PC before. It seems pretty strange for it to just start doing this at the exact same time I did these OS changes.
     
  4. thread starter macrumors 68020

    Heb1228

    Joined:
    Feb 3, 2004
    Location:
    Virginia Beach, VA
    #4
    Ok here's a little more info. Before I wiped the drive I cloned it to an iPod. I can boot off the iPod back into the old setup and it seems to sleep normally: the iPod seems to sleep (as much as I can tell) and the internal drive sleeps as well.
     
  5. macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #5
    Sounds like you need the original install discs to format the hard drive correctly.

    I think I have the iMac 400 discs and the iMac 500 discs and maybe another set... my mom had the 500 and a friend had the 400...

    Let me know if you want them cheap. You do need a new hard drive, too. You are limited to a 128gb total.
     
  6. thread starter macrumors 68020

    Heb1228

    Joined:
    Feb 3, 2004
    Location:
    Virginia Beach, VA
    #6
    I have the original discs but I don't really see how that's an issue... I can boot from a Panther or Tiger install disc and format the drive from there. Am I missing something?

    I guess I just need to open up the case and stick a different hard drive in to see if that fixes the problem.
     
  7. macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #7
    I could be wrong but I always start formatting on a new hard drive on Macs with the original software discs and work my way up to the latest OS.

    Max the ram and get a new hard drive.
     
  8. macrumors 6502a

    three

    Joined:
    Jan 22, 2008
    Location:
    Washington State
    #8
    My G3 does the same thing, the HD is a monster 7GB, and it's very very loud.
     

Share This Page