1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

G4 733MHz Quicksilver not starting. HELP

Discussion in 'PowerPC Macs' started by Ziklag PCSVCS, Feb 13, 2009.

  1. macrumors newbie

    I have a G4 733MHz Quicksilver here. This is the problem. I press the power button the light flashes, the fans spin, and nothing. Repeat and still.....nothing. I checked to see if all the components were seated, ram, logicboard, video card. Tried again and............ nothing. I reset the PMU aaaannnnd...... Nothing. Checked over everything and noticed that the little red LED on the board is not illuminating. However there is power running through the board because the power button light is comming on, fans are spinning up. However it will not fully come on. I also changed out the logicboard. And that wasn't the issue. So does anyone know what I have going on here. This is killing me, cause I have given myself a headache trying to figure this out. Please send me a reply or email me, something please.......
  2. macrumors 68000

    Sounds like either Bad RAM or a Bad CPU (if you dont get the Bong) If you do get the bong then its likely to be the video.
  3. macrumors regular

    Sounds more like a ****** power supply to me, you'd hear some beeps if it was bad RAM. If you look inside the power supply and see lots of caked up dust inside and on the fan this is very likely
  4. macrumors 68000

    The Power Supply cant be bad as the light on the front came on, it might be that you need to do some fancy power routing as its overloaded, or get a more powerful PSU (or its just a bad board), as I believe Al DiBlasi (youtube - adiblasi) had the same when he upgraded his Digital Audio G4 (same architecture and clock speed, just different case)
  5. macrumors Penryn


    I'd take a look at the PRAM battery.
  6. macrumors 65816


    It's a bad PSU - I had the exact same problem, with the exact same symptoms, back in the day with my Blue and White. Shouldn't be too expensive to switch out.
  7. macrumors newbie

    Thanks All

    Well I have switched out the RAM so many times that I can't remember which was the RAM in it when I got it. That doesn't seem to be the promblem. I have also purchased a new CPU and tried that. It didn't work either. PSU has some dust, however not caked. However I get lights in the front, but the little red LED on the motherboard is not lighting up. Tried replacing the PRAM battery and still nothing. I have 3 other G4's, 1 other Quicksilver. All of their boards have the LED lighting up. Does anyone think that it could be a bad board??????? Curious............. I was up until 5am that night trying to figure this out. :mad::(
  8. macrumors Core

    I have a 733 QS and the PSU failed. When you pushed the power button it would light up. But the machine would do nothing more.

    Replaced the PSU and it works as well as it ever has done...

Share This Page