G4 ibook freezes when you move it - ideas?

Discussion in 'PowerPC Macs' started by britten440, Jul 10, 2006.

  1. macrumors newbie

    Joined:
    Jul 10, 2006
    #1
    Hi everyone,

    I'm having a problem with my g4 ibook, and since its out of warranty and i don't have the APP, i was hoping we could narrow down whats happening.

    The computer runs great when i use it on my desk... however if i pick it up to move it or even bump it lightly, it will freeze. By freeze i mean the mouse cursor still moves, except that its like the background and programs are frozen: you cant click on anything, nothing responses, and nothing happens besides being able to move the mouse around. I took it to the Apple store and all they told me is that its something in the logic board and they would have to send it in... I have taken out the additional memory, had no USB devices in and booted up from an external hard drive, but the computer still freezes.

    Any ideas what to look for when i open the computer up? is it possible the built in 256 MB of memory is slightly loose? Its obviously not the hard drive, video card or screen since the cursor still moves... any help would be very appreciated
     
  2. macrumors 65816

    yankeefan24

    Joined:
    Dec 24, 2005
    Location:
    NYC
    #2
    Does your model have the sudden motion sensor? This (to me) seems like the most likely problem if you have it.
     
  3. macrumors 65816

    MIDI_EVIL

    Joined:
    Jan 23, 2006
    Location:
    UK
    #3
    It must be the harddrive, and if it does have sudden motion sensor, it is probably on it's way out.

    I am sure the iBooks did not.

    Rich.
     
  4. macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #4
    That signifies that the iBook is pre-SMS so it couldn't be that. When did the problem start? Have you dropped the iBook?
     
  5. macrumors G4

    Mord

    Joined:
    Aug 24, 2003
    Location:
    Old York
    #5
    it's the HD, the cursor will move as it's running off the memory but no new data will load.
     
  6. thread starter macrumors newbie

    Joined:
    Jul 10, 2006
    #6
    I don't think its the hard drive

    I did drop it once.. over a year ago and its worked fine since... i don't see how it could be the hard drive since the apple genius booted my computer up from a external drive and when i moved the computer (not the HD) it still froze.. is the SMS separate from the hard drive?

    the problem started suddenly out of the blue about a week ago... never had a single problem with it before... it is manufactured in September '04 if that helps to figure out if its pre-SMS
     
  7. macrumors G4

    Mord

    Joined:
    Aug 24, 2003
    Location:
    Old York
    #7
    ok ok, then their may be a loose screw which shorts something out when you move it.
     
  8. macrumors 6502a

    Laser47

    Joined:
    Jan 8, 2004
    Location:
    Maryland
    #8
    ibooks made after July 2005 have the SMS sensor, but I dont think its the hard drive. The programs should still be at least somewhat responsive because the program is loaded into memory. For instance on my ibook when the HD goes to sleep im still able to click on things, even before the HD starts spinning up.

    Its most likely the logicboard, it cant be the built in ram because its soldered in.
    Have you tried the apple hardware test, see what it reports back.
     
  9. macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
  10. thread starter macrumors newbie

    Joined:
    Jul 10, 2006
    #10
    definately pre-SMS

    my hard drive definitely is pre-SMS... and I'm familiar with the hard drive stall when you have to wait for it to response after it is asleep... this is definitely not something similar....

    weird thing is there is nothing to signal that it is frozen... oddly it goes from being responsive to frozen in a split second...

    also.. no matter how long you leave it.. it stays frozen..

    apple genius said it was possible there was a loose connection or a short somewhere on the logic board...
     
  11. macrumors G5

    Sun Baked

    Joined:
    May 19, 2002
    #11
    Oops sorry, that was a G3 thing -- but a loose connection or frayed wire is still a possibility.

    Can happen in high stress areas like the hinge.

    Though it may indeed be the HD. Since the HDs are prone to failure in portables.

    Like the battery, they almost seem to be consumables. :(
     
  12. macrumors 68000

    disconap

    Joined:
    Oct 29, 2005
    Location:
    Portland, OR
    #12
    Did you run disc utility and check the SMART status?
     
  13. macrumors G4

    Mord

    Joined:
    Aug 24, 2003
    Location:
    Old York
    #13
    it's pretty much solid that it's not the HD as it behaves the same way when booted from an external.
     
  14. macrumors newbie

    Joined:
    Jul 10, 2006
    #14
    Mine does the exact same thing. Any idea how much it would be to repair? (i don't have Applecare either). I'm pretty sure it isn't the hard drive and there's no sms on mine.
     
  15. thread starter macrumors newbie

    Joined:
    Jul 10, 2006
    #15
    could be in the hinges? uh oh....

    Not good... i was hoping it didnt have to do with them because the hinges are a little bent from the one fall... but just using common sense.. i dont get how it could be wiring going to the display.. it works fine... because it displays my cursor moving across the screen.. now if the whole screen froze, i could see that as an issue...

    I guess if something is shorting the computer out somewhere, it really could be anywhere..

    I guess i'll open the ibook and study the logic board well and the wiring along the hinges... any other spots to check out?

    another issue i have with it but i don't think its related is that the computer will shut off random if its not plugged into the power supply.. no matter how much battery it displays.. im just guessing the battery is shot but just decided to mention if they are possibly related... thanks guys
     
  16. macrumors newbie

    Joined:
    Aug 4, 2006
    #16
    Mac support reply

    I've got the exact same problem, and tried all of the above without luck. So I gave it to Mac support and they said they could fix it (think they wanted to replace the logic board) for an amount very close to what I once paid for it, so I declined and went back to my laptop/jet-engine/pc/crap machine. BUMMER
     

Share This Page