G4 MDD 1.25 - Can't reinstall the original OS

Discussion in 'PowerPC Macs' started by goMac, Mar 31, 2013.

  1. macrumors 603

    #1
    I'm having trouble with a G4 MDD 1.25. I'm trying to install the original OS, so I can use the restore CDs and reinstall Mac OS 9 with it. I can boot from cd and start the reinstall just fine. But as soon as it restarts, it gets past the loading screen and just stops. Cursor is moving, but screen stays blue, no matter how long I leave it.

    I've tried different disks, wiping them fresh each time, and still can't get 10.2.1 (original OS version) to boot on the thing. Anyone have any ideas?
     
  2. macrumors 65816

    Lil Chillbil

    #2
    The Mdds depending on which model firewire 800 or 400 can't run os 9.
     
  3. goMac, Mar 31, 2013
    Last edited: Mar 31, 2013

    macrumors 603

    #3
    It's definitely a FW400. The original restore disks have Mac OS 9 as well.

    I intentionally picked up a FW400 for running OS 9.

    Edit: An update,

    According to the system logs it's getting stuck repeatedly at:
    "NetInfo connection failed for server 127.0.1."

    Very puzzling as it does it from a fresh install.
     
  4. macrumors 6502a

    PowerPCMacMan

    #4
    goMac,

    Hey how are ya? Welcome to the PowerPC forums!!! Have you tried a PMU reset? The PMU button is located on the logic board I think around the memory area.. Tap that for about 5 seconds with your other finger holding down the power button.

    Then quickly go into open firmware.. Cmmd+Opt+O+F - Type the following

    reset-nvram
    set-defaults
    reset-all

    This should restore the MDD back to factory default.. You should then be able to boot from the install discs and re-install the OS. If not, you might not have the right disc set. If this is the case, I have them if u need em'

    I have owned an MDD 2003 Dual 1.25 w/2MB L3 Cache and it was a slick machine.
     
  5. macrumors 603

    #5
    Yeah, I've tried all of the above - no go. :(

    The weird thing is it will boot 10.5 just fine. Which is great, but I'd like to play around with older OSs on it, and the OS 9 restore app won't work in 10.5 either.

    I'm starting to suspect logic board. I get some weird messages in Open Firmware when I boot into it, (sometimes about USB, sometimes about self-ids failing, I can check the exact messages when I get home.) I've seen this before where a certain component has failed, but the OS can either adapt by dropping the driver or just not boot.

    I've got a replacement logic board and CPUs lined up for not too much, but I'd feel better if I could find more info about the exact issue.

    Neat machine, wanted an OS 9 speed demon. The hard drive configuration is kind of bizarre though, and I already have power supply fan replacements on order.
     
  6. macrumors 6502a

    PowerPCMacMan

    #6
    i know this doesn't solve the problem.. but remember that the MDD's shipped with a special OS 9 enabler.. A standard retail OS 9 disc will not work.. But if you already tried this.. I can only assume the LogicBoard is bad..

    Get a new one and I think the problem will go away.. Also, check your memory.. As you may recall like I do, the PowerPC machines were very picky about the type of memory. These problems could very well be because of BAD memory.
     
  7. macrumors 603

    #7
    Yeah, it's not a retail OS 9 disk, it's the original restore media. Verified that it's actually a match for the machine.

    Was looking at the memory. It looks like an original stick (yay), but I don't think I have any more DIMMs of the same type (boo). I may want to check that out as well.
     
  8. macrumors 6502a

    PowerPCMacMan

    #8
    I am starting to think this might be a memory problem.. DDR 3200 or 2600 can be had for very low prices these days.. It may not be a bad idea to get new memory for it and see if it repeats the same problem.. If so, then we know its not the memory.. it could only lead to then the motherboard..

    New MDD logicboards are really inexpensive these days.. Might even want to get the Dual 1.42 processor and swap out the 1.25.

     
  9. macrumors 603

    #9
    I'll check. I started on this project a few years ago, and I could swear I remember it came with more than one DIMM and I did some swapping as part of a test, but there is only one DIMM in there right now and I haven't seen any spare DIMMs around, so maybe I was wrong.

    I was kind of leaning away from a memory problem because it boots fine with 10.5 but you never know.
     
  10. macrumors 6502a

    PowerPCMacMan

    #10
    Yeah, that would be a leaning away in regards to the memory... but try it.. perhaps OS 9 is finicky about the memory thats in there while Leopard sees it as ok. Odd, if u ask me. Its good you have some interest left in PowerPC machines.. Perhaps you can help us to support the platform from oblivion?


     
  11. macrumors 601

    GermanyChris

    #11
    The fact that it boots to 10.5 without issue would seem to preclude a HW issue of any nature really..

    I wonder if there was a firmware updated somewhere along the way that removed/hindered the ability to run OS9..Apple/Steve wasn't a real big fan of OS9.
     
  12. macrumors 6502a

    PowerPCMacMan

    #12
    I had the same machine as goMac, but mine was a dual 1.25 w/2MB L3 Cache and without FW800.. I never experienced a problem like what he is having on mine, at least when I owned one.

    I am somewhat stumped at what it could be. You are right that if it boots into Leopard, then its not a hardware issue.. dunno at this point as this has never happened on my MDD 2003 when I had one.

     
  13. macrumors 603

    #13
    I've seen it as a hardware issue before on different PowerPC hardware. Usually a certain controlled fails, and one OS can recover from the failure, one OS can't. Last time I saw this was with the firewire controller.

    The fact that I get weird messages every time I boot into OF also makes me think hardware. Although I can't find a good guide on what self-ids failed even means.
     
  14. macrumors 6502a

    PowerPCMacMan

    #14
    At this point since MDD logic boards are quite inexpensive, just get a known working one or sometimes you can get a new one off Ebay. Its not worth it to try and diagnose this problem.. A new board will solve everything and its even under 100.00

     
  15. macrumors 603

    #15
    Update: Swapped the RAM, no difference. Still haven't swapped the mobo yet. Some research indicates the OF messages I'm seeing are coming from the FW controller.
     
  16. macrumors 6502a

    PowerPCMacMan

    #16
    At this point, replace logic board... Sounds like FW controller is messed up.

     
  17. macrumors regular

    #17
    Not too long ago, I had a firewire port acting up on one of my MDD's. I researched the problem on Apple's Support forum and found a temporary solution.

    In my case, the computer would hang at the blue screen for almost exactly 6 minutes before finally booting. The logs indicated it had something to do with firewire. And when it finallly booted, the firewire ports were dead.

    The solution was to unplug the power cord from the unit, then hold the power button in for at least five seconds. Then plug the power cord back in and hit the startup button. My computer would then boot correctly and the firewire port would function. I'm guessing that the firewire port was somehow "reset" using this technique.

    The solution was only temporary though, as the condition would return after only a few startups. I eventually purchased a new motherboard on eBay for $35, and that solved the problem for good.

    I don't know if this will work for you, but it's what worked for me. Anyway, it only takes a few minutes to try it. Good luck!
     
  18. macrumors 6502a

    PowerPCMacMan

    #18
    He tried that already, so I advised him to just go and get a new board.. MDD boards aren't that expensive anymore.

     
  19. macrumors regular

    #19
    Oh, sorry. I must have missed that. A new board is what ultimately worked for me, too.
     
  20. macrumors 6502a

    PowerPCMacMan

    #20
    No problem, man... we are all here to help anyone in need. Sometimes when you troubleshoot something and you give it your best shot with no results, its best to buy a new part..

    It happens all the time.



     

Share This Page