G4 MDD won't turn on

Discussion in 'PowerPC Macs' started by daezaez, Aug 24, 2009.

  1. macrumors newbie

    Aug 24, 2009
    Hi all, I'm new here and I've tried to give a good search to see if this question can be answered without posting... alas I could not find one that would solve the problem so... here it goes:

    I have a nearly 5 year old G4 MDD that will not turn on. It's plugged in to the wall and the computer itself. Checked this several times. It doesn't matter if I try via the monitor or the tower. Nothing happens. I'm HOPING that it's the PRAM battery as I THINK I had a similar problem in the past. I don't recall the particulars as it was about 3 years ago and I'm about to try replacing the PRAM battery first before getting more drastic like replacing the power supply and what not.

    The question I have... could this be a simple PRAM battery issue or am I looking at something more involved like a power supply issue? Any thoughts/suggestions on this will be MUCH appreciated! I'd love to get this beast working again so I can finish up my album. :)
  2. macrumors 6502


    Apr 7, 2009
    I also have a G4 MDD that was having similar problems, and I fixed them by removing a hard drive.

    I think the power supply on mine is marginal enough that with a Radeon 9800 Pro, 2 PCI cards, and 4 hard drives installed, there wasn't enough power to run things reliably. Sometimes it wouldn't restart (just shutdown). Sometimes it wouldn't power on at all (bezel light would light up when presses, then go dark and nothing would happen). Sometimes it would crash or randomly reboot.

    Replace the PRAM battery, reset the PMU (be careful on that one), pull out any unnecessary hardware.

Share This Page