g4 wont start up

Discussion in 'Macintosh Computers' started by edward0912, Nov 15, 2003.

  1. macrumors newbie

    Joined:
    Nov 15, 2003
    #1
    My G4 Silver wont start up when I push the "on" button... The light stays on as long as I push the button... When I release the button the light goes out....
     
  2. macrumors P6

    wdlove

    Joined:
    Oct 20, 2002
    #2
    Do you still have Apple Care? Have you tried starting up from your Mac OS software while holding down the C Key? I would check all of the wire connections. If you live near an Apple Store or an authorized dealer you could contact them or take it in, many times hands on is helpful. I'm the T&E type with my Mac.
     
  3. macrumors 68000

    MoparShaha

    Joined:
    May 15, 2003
    Location:
    San Francisco
    #3
    Have you tried the PMU reset button on the motherboard. It's a small button somewhere on the MB. Turn the machine off and unplug it, and press the button, see if that works.
     
  4. macrumors 603

    Dont Hurt Me

    Joined:
    Dec 21, 2002
    Location:
    Yahooville S.C.
    #4
    edward needs to give details, whats in his machine and whats connected??what was he doing lately?
     
  5. macrumors 68000

    Spock

    Joined:
    Jan 6, 2002
    Location:
    Vulcan
    #5
    Sounds to me like You need to replace the Pram battery
     
  6. macrumors 6502a

    Joined:
    Jul 22, 2002
    Location:
    Tampa
    #6
    had the same problem

    I had the exact same problem a few months ago. I had to take it to the Apple store and they had to "reset the logic board." It cost 50 American.

    I wonder if anyone here knows how to do it on your own. But if you'd rather not risk trying to fix it $50 isn't a bad price to make your Mac work again.

    BTW, it probably got zapped during a lightning storm or something. That's what happened to me. Good times.

    Matt
     
  7. Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #7
    Re: had the same problem

    The free way is, as noted earlier in this thread, is to press the CUDA/PMU button. This "resets the logic board". Locate the button on your logic board, press and hold for a count of 10. There is much debate on if this is too long to hold it, but in an instance like this when your machine will not power up, 10 is the number to count to. Not 2, not 3, 5 is right out.
     
  8. macrumors member

    Joined:
    Jul 29, 2003
    #8
    Re: Re: had the same problem

    Not quite correct - this method can crash the PMU (power management unit) which is what is actually being reset. First step should be to unplug the power cord. Next, you should verify the battery voltage (3.3-3.7 volts) and replace the battery if needed. Press the button ONLY ONCE. You can feel the "click" as the reset button engages. Wait 10 seconds (perhaps where the idea of holding the button for a count of 10 came from). Plug power cord back in and see if the unit powers up. If not you have something else wrong and may need more expert help.
     
  9. Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #9
    I had the exact same trouble that the original poster had and simple clicking the CUDA reset button and waiting didn't do anything. I still could not get the machine to boot. I contacted Apple Support and was told to press and hold the button for 10 seconds. After that it booted just fine.
    Make of that what you will...
     
  10. macrumors member

    Joined:
    Jul 29, 2003
    #10
    Thanks! I'll make it part of my troubleshooting tools. Not mentioned anywhere in Apple's technical documents, but I've had some good tips from Apple Tech Support that aren't documented. So I'll take this as one of them.
     

Share This Page