G5 Quad starting to play up- on it's last legs?

Discussion in 'PowerPC Macs' started by ClivePwned, Jan 10, 2010.

  1. macrumors member

    Joined:
    May 25, 2009
    #1
    Hey all- my 4 year old g5 Quad has started recently playing up.

    Today whilst working on Logic 7, the thing froze (which is unusual in itself)
    with a what looked like Terminal Text overlaid mentioning something about problems with CPU 2 and CPU3. It was a session playing back one drum loop and I was laying down a simple acoustic guitar riff with no effects or plugins being used. The sound card is a Digidesign pro Tools HD3 with a 96 io.

    I restarted the machine and of course the fans went nuts and the thing froze during boot up. Another restart and I had the OSX logo on a folder icon appear and after another restart it appears to be working. Last week it did something similar where it locked up but a restarted cured that. I replaced the HDD's about 6-7 months ago and upgraded the ram to 16GB.
    It has very occasionally displayed strange behaviour but since nothing has been changed or updated in a long while. The machine has been so reliable that it is quite noticeable when it suddenly stops like that.

    Any ideas? I had hoped to keep this machine at least until the 2010 MP's come out.
     
  2. macrumors 68040

    rickvanr

    Joined:
    Apr 10, 2002
    Location:
    Brockville
    #2
    check for coolant leaks
     
  3. thread starter macrumors member

    Joined:
    May 25, 2009
    #3
    I've looked and can't see any any liquid or signs of corrosion from the coolant.

    It's locked up a few times since I first posted, with the fans going nuts all of a sudden when the computer is idling
     
  4. macrumors 68020

    gugucom

    Joined:
    May 21, 2009
    Location:
    Munich, Germany
    #4
    The 90 nm versions of the PPC CPUs (from 2004-2006) are all subject to short CPU life and high failure rates. They had a problem with the silicon process using IBMs new galvanic processes.
     
  5. thread starter macrumors member

    Joined:
    May 25, 2009
    #5
    makes sense. 4 years isn't bad for a computer. Just would have liked at least two-three months use until the new MP's are out.

    Got this when I booted up this morning
    [​IMG][/URL][/IMG]

    I reseated the RAM and reset the nvram. Hopefully that will buy me some time.

    EDIT: has worked fine since I did the above. so far so good
     
  6. macrumors newbie

    Joined:
    Jan 11, 2010
    #6
    Similar problem

    I've got similar issues going on w/my PowerMac G5 that I purchased in 2004... I had it looked at by Apple and they tell me at its a processor problem... and since my Applecare expired, they want 1200 bucks to repair. The good news is that the hard drive is fine and it still boots up once every 7-8 tries, so I was able to recover all my info...
    It was a good run, time to move on up...
     
  7. macrumors 6502

    LEStudios

    Joined:
    Apr 24, 2007
    #7
    I was actually considering a Quad G5, but if they have these kind of issues I rather buy another Mac mini. Mac mini at least have Core Duo 2 by processing power does a whole lot more. I did a benchmark where my Early 2009 2GHz Core Duo 2 with 3MB Cache Mac mini was more powerful than the Dual 2GHz PowerMac G5. I know you be able to do more far as music and HD Video as well. Maybe this helps if finance is a issue. :)
     
  8. macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #8
    What happens in the Powermacs is that the processors get unseated slightly. Chinese manufacturing.

    I had a 2.0 Dual Core that was not working at all. I packed it up to go to the repair shop.

    On the way to the elevator, it took a slight bump to the carpet and fell off the dolly on it's side.

    Viola.

    That machine worked perfectly after that. It was amazing.

    I'm not recommending this with PMG5s that you drop them on a soft surface.

    But I am saying that these are great machines and you really need someone who knows what they are doing to reseat the processors when necessary. Some article on it somewhere on MacRumors.

    I am running a friend's 2003 FIRST Generation 2.0 Dual Processor (not dual core) Powermac at moment.

    The thing was taken care of, it is silent and fast and sorry, it's just as fast if not faster than my 2.26ghz Mac Mini.

    Granted, I looked up the S/N and hey -- this machine was manufactured in California, not China. Don't know if that's the difference but this this is fast and quiet.
     
  9. thread starter macrumors member

    Joined:
    May 25, 2009
    #9
    well it's been fine since fiddling with the RAM so we shall see.
     
  10. macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #10
    So the first generation G5s did not have this problem, i.e from 2003?
     
  11. macrumors regular

    Joined:
    Jul 11, 2004
    #11
    Maybe not but they had sheet-ty power supplies and poor performance esp the 1.8 ghz single cpu model
     

Share This Page