1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

G5 that can't read/write to external drives well

Discussion in 'PowerPC Macs' started by statikcat, Sep 17, 2007.

  1. macrumors 6502


    This issue has been killing my work flow for quite awhile. I have a G5 dual 2.0. I can barely read or write files to an external hard drive. Say I try and copy 1.56GB of audio (12 files) from my external drive it will start to copy then stop at 500mb for minutes.. then start moving as normal and stop again around 900 for minutes.. then again at 1.4. So annoying! This also happens when writing.

    Here is the confusing part. This happens with two external drives (different models) with firewire 400, 800 and USB. I have reinstall OSx. I have repaired permissions and ran repair disc on everything. These hard drives work FLAWLESS with my Macbook Pro as well. Gr what can this be? It takes FOREVER to copy data to or from a drive which is often how I transfer audio between my desktop and laptop. I should soon have Mac Pro money and this crappy G5 can go out the window. It is seriously the worst computer I have ever owned! Anyway, any suggestions? I am on 10.4..
  2. macrumors 6502


    It also was doing it yesterday when just copying files from a DVDr. If no one here even has any ideas or clues then I guess I am stuck dealing with this for now. I am going to Office Space this G5 soon.
  3. macrumors 6502a


    two different drive enclosures with the same drive? or two different drive enclosures with 2 different drives?
  4. macrumors 6502


    1 is a WD Mybook w/ USB, Fw400+800 and the other is a 500gb drive in a Coolmax enclosure with USB + FW400. Two different drives. They both work fine on my Macbook Pro and they both get a lot of use as I use my Macbook at work and the hard drives almost every day. @ Home on the G5 they barely work. This makes me think the motherboard is having issues in the G5.. but it has this issue on USB and Firewire and I am pretty sure they are using different controllers. Internal drives copy just fine between each other. My other usb devices, such as usb audio and midi, mouse, keyboard, all work fine. My firewire audio interface works fine as well. So other forms of data work on these connections fine.. just not external hard drives. :eek: (and yes I have tried multiple cables). I have also low level formatted the Mybook drive which also took a VERY long time!
  5. macrumors 6502a


    Disable spotlight for that drive. It is probably trying to index the drive again and again.
  6. macrumors 6502


    I disabled spotlight for the external drive and the same thing. I just tried to drag a folder and it got stuck on 2mb of 336.3mb. When I hit cancel (x) it takes awhile to even stop the operation. =-(.. ugh. I think Mac hd format just sucks hard..

    thanks for the suggestion though.
  7. macrumors member

    I am having the same issues but on a MacPro quad 2.6 and have been trying to figure out what the hell it could be. I can also use the USB and Firewire ports just fine for anything except external drives.

    I've tested many USB 2 and firewire 1 drives on multiple computers since then. All work on my laptop and other computers but none work on my desktop. Most of the time they won't mount on the MacPro but when they do the transfer speed is horrible and never completes without locking up. Other USB and firewire devices still work on my desktop however.

    I don't want to go off topic with all of the other issues I have had with my MacPro since I got it (first week it came out) but whatever they are, I hope we can get to the bottom of them soon because my $5,000 computer setup is used less now than my old and ridiculously awesome powerbook g4!
  8. macrumors 6502


    Ha.. well I am glad I am not the only one with this bizzare issue. It seems maybe the problem is not related to G5 vs Mac Pro. I have tried everything, even reinstalling OS to try and fix it.

Share This Page