1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

G5 won't boot: OHCI not sticking

Discussion in 'PowerPC Macs' started by borat3, Aug 25, 2010.

  1. macrumors newbie

    #1
    Hi all,

    So I was running my PPC G5 with a lot of processes and the whole computer froze, not just one application. I held down the power button on the tower until it shut off and then waited and turned it back on but it wouldn't start. Now whenever I turn it on, it goes to the gray startup screen with the apple and the loading "gear" and stays there, while the fans begin to run loud and fast. I tried resetting the PRAM with no luck, safe mode will not work, and when I ran in single-user mode, it came up with this error a bunch of times until I just turned it off: OHCIRootHubPortPower bit not sticking. I only have the keyboard and mouse attached to the computer, nothing else. Any ideas?
     
  2. macrumors 6502

    #2
    Well, OHCI stands for an Open Host Controller Interface and it is used for USB 1.1, which is the specification that a keyboard and mouse run at. Try unplugging the keyboard and mouse and then try to boot.
     
  3. macrumors newbie

    #3
    No luck with unplugging the keyboard and mouse. Any other ideas? I feel like I just overloaded the system and then forced the shut down and now it just won't turn on :(
     
  4. macrumors 68040

    666sheep

    #4
    Seems like some of system files are screwed up or HDD gone bad. Start with Verify/Repair Disk in Disk utility (boot from OS Install Disc) or check your HDD with fsck in single user mode.
     
  5. macrumors newbie

    #5
    Unfortunately, I don't have the install disc for this computer :( Really limits my options. I ran fsck in single user mode and that "OHCIRootHubPortPower bit not sticking" came up almost immediately and then it just repeated that error.
     
  6. macrumors 68040

    666sheep

    #6
    Disk Warrior?
     
  7. macrumors newbie

    #7
    I'm not very familiar with Disk Warrior, but wouldn't you probably need the install disk to use it, in which case I don't have it?
     
  8. macrumors newbie

    #8
    Great Success! I was just able to start it up in Safe Mode using Shift-Command-V :) Here are some potential errors I saw a ton: appleintelcpupowermanagement isn't a valid mach-o,
    error mapping module file com.apple.driver.AppleIntelCpuPowerManagement,
    OHCIRootHubResetResetChange bit not sticking

    I'm now able to use the computer should I run Disk Utility now? I'm scared to turn it off because it may never come back on haha
     
  9. macrumors 6502a

    #9
    well appleintelcpupowermanagement should not be on a ppc system maybe a trick i have used on hackintoshes might help and that is to delete the appleintelcpupowermanagement.kext from the extensions folder and rebuild the extensions.mkext with a program i think is called mkext utility
     
  10. macrumors newbie

    #10
    Yeah it doesn't make sense that there would be an Intel file on a PPC Mac. Not 100% certain what a Hackintosh is, but I don't think this Mac is a hackintosh :) Everything on it is legit and by the book because it was previously owned by a strict company and I just got it for free cuz they were going to trash it. Everything is original parts, Ram, etc.
     
  11. macrumors newbie

    #11
    Forgot to mention: When I was in safe mode, I deleted the partial applications/files that I was installing before the computer crashed and then restarted the computer in normal mode and it worked perfectly. The computer so far starts up and runs fine now :) I don't know whether it was because I deleted those incomplete files or if it was from just running it in safe mode. Hopefully it continues to work.
     
  12. macrumors 68040

    Giuly

    #12
    It just says that the kext does not contain PPC code, which makes sense, as you can't control any Intel-CPU in a PPC Mac. Feel safe to ignore.
     
  13. macrumors 6502a

    #13
    a hackintosh is a pc with mac osx installed on it (like the advent 4211 in my sig) and on some systems the appleintelcpupowermanagement.kext will cause the system to hang in boot
     
  14. macrumors 6502a

    VanneDC

    #14
    backup what you need, the repair permissions using disk util. if that fails,
    \aliens
    take off, nuke the joint from orbit, only way to be sure!
    \aliens
    then re-install
     
  15. macrumors newbie

    #15
    Thanks for all the advice. The computer has been working perfectly ever since. If I ever have any more problems I know this is the place to come frantically. Thanks again :)
     

Share This Page