G5 won't boot

Discussion in 'iMac' started by cocoatronik, Aug 31, 2011.

  1. cocoatronik, Aug 31, 2011
    Last edited: Aug 31, 2011

    macrumors newbie

    Joined:
    Sep 13, 2008
    Location:
    Minneapolis, MN
    #1
    I have a 2005 iMac G5 17" ALS (Ambient Light Sensor) that will not boot.

    When I attempt to boot from the hard drive, the gray screen with the Apple logo and spinning icon appears, followed by the blue screen, and then it freezes with a spinning beach ball on the blue screen.

    I've tried to boot from a CD/DVD, using both the original Tiger OS disk that came with the machine and the Leopard install disk that was used to upgrade it. When I try holding the Command key while booting, the startup manager opens, displaying the HD as an option. But when I insert the disk, it spins around for a while (with the cursor a timer icon), and eventually just ejects the disk without ever showing it as a boot option. Clicking on the refresh button does not help. When I try holding the C key while booting (with the disk already in the drive), it spins around while displaying the gray screen (without the Apple logo), and then ejects the disk. After ejecting, it attempts to boot from the HD (gray Apple logo screen, followed by freezing on the blue screen).

    Other details:
    • I've reset the SMU (by removing all cables, then reconnecting the power while holding down the power button).
    • I've reset the PRAM and NVRAM (using Command+Option+P+R).
    • I've switched the RAM modules.
    • I've tried unplugging all peripherals.
    • Internal diagnostic LEDs 1, 2, and 3 all indicate normal function.
    What does it mean when it just ejects the CDs/DVDs like this? Does that indicate a logic board problem? What else can I try?
     
  2. thread starter macrumors newbie

    Joined:
    Sep 13, 2008
    Location:
    Minneapolis, MN
    #2
    Lost cause?

    I'm gathering there is nothing left to try.

    I'll wait a few more days to see if there are any suggestions. Otherwise, I'll pull out the HD and drop the machine off for recycling.

    :(
     
  3. macrumors 6502

    jaikob

    Joined:
    Jul 1, 2008
    Location:
    Freeland, MI
    #3
    Hold the command key and S while booting. This will take you to single user mode.

    Can you get there?
     
  4. cocoatronik, Sep 14, 2011
    Last edited: Sep 14, 2011

    thread starter macrumors newbie

    Joined:
    Sep 13, 2008
    Location:
    Minneapolis, MN
    #4
    Single-User Mode

    Thanks for the response! Yes, I was able to enter single-user mode. Once there, I ran file checks using fsck -y, and then fsck -f, with the following results…

    :/root# fsck -y
    ** /dev/rdiskOs3
    ** Root file system
    ** Checking Journaled HFS Plus volume.
    fsck_hfs: Volume is journaled. No checking performed.
    fsck_hfs: Use the -f option to force checking.

    ***** FILE SYSTEM WAS MODIFIED *****
    :/ root# fsck -f
    ** /dev/rdiskOs3
    ** Root file system
    ** Checking Journaled HFS Plus volume.
    ** Checking Extents Overflow file.
    ** Checking Catalog file.
    ** Checking multi-linked files.
    ** Checking Catalog hierarchy.
    ** Checking Extended Attributes file.
    ** Checking volume bitmap.
    ** Checking volume information.
    ** The volume Macintosh HD appears to be OK.
    :/ root#


    (When I typed "exit," it eventually got to the blue screen, then faded to a black screen with a white vertical stripe down the middle third of the screen, where it hung up.)

    I don't know what to look for, but one thing that stood out to me in single-user mode was a line...

    AppleSMU -- shutdown cause = 3

    Isn't AppleSMU the power management chip (Systems Management Unit)? Is this indicating a problem, or is that normal in this mode?

    What else should I try or look for in single-user mode?
     

Share This Page