G5 Won't Sleep Automatically

Discussion in 'macOS' started by Makosuke, Nov 1, 2005.

  1. Makosuke macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #1
    My trusty G5 DP 2.0 (first gen) recently seems to have lost the ability to fall asleep by itself. I had been assuming I had some app open that prevented sleep, but after installing 10.4.3 and restarting, it still refuses to nodd off even with nothing ever launched, so it must actually be a problem.

    It will still sleep and wake manually (menu or the button on front... the fan "whoosh" on wake has changed with .4.3), and the odd thing is I haven't installed anything new that I can remember recently. I've tried all the obvious: restart; reset PRAM; boot into OpenFirmware and do the standard resets; shutdown, unplug power, pull motherboard battery, wait, and restart; repair permissions and fsck; I installed 10.4.3 using the combo, not incrimental updater; unplugged all external devices but speakers, keyboard, mouse, and my Apple monitor. None had any effect.

    The only thing I haven't done is pulled my external SATA card (FirmTek), but the attached drives aren't even powered up and it didn't cause any issues most of the time I had 10.4.2 running.

    Any thoughts? Searching the boards came up with nothing...
     
  2. tech4all macrumors 68040

    tech4all

    Joined:
    Jun 13, 2004
    Location:
    NorCal
    #2
    What exactly do you by that? How has it changed? I have yet to update so I'm not sure what that means exactly.
     
  3. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #3
    Well, before when you woke it, first there'd be the click of powerup, then immediately after a relatively quiet "vroom" sound from all the fans (isn't it supposed to be knocking the dust off?), then maybe a few more clicks as the hard drives finish spinning up or whatever, and the computer's awake.

    With 10.4.3, it's been more like: Power up click, smaller fans make a very quiet "whoosh", then a second or two later the main fans make a much louder "vroom" (they spin up a little higher than they used to), then it finishes powering up and is ready. It basically sounds like they've maybe staggered the fan spinups, and probably cranked them up a little higher (maybe that's why they staggered it--to keep it from being too loud when revving up). Oddly, it doesn't seem to be 100% consistent, though that might just be me.

    I'd noted folks complaining about more fan activity, and although I noticed the fans revving up more than usual right after install, it seemed to settle down very quickly and hasn't done anything odd since; perhaps the update just takes a bit to adjust to current ambient temperatures or something.

    Oh, by the way, on the original issue, I've also tried another user account (with only that account logged in, of course), and deleting the relevant plist files, neither of which helped.
     
  4. hhlee macrumors 6502

    Joined:
    May 19, 2005
    #4
    my rev b dual 2 does the same. power management seems a little haywire - no auto sleep and wakeup is messy (sometimes it takes a long time before input devices work) i have no additional hardware either - it may just be the software.
     
  5. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #5
    My iMac G5 is also struggling to fall asleep of its own accord since 10.4.3. I've been looking through Activity Monitor to see if there's a process that looks like it'd keep everything awake but I haven't had any luck yet. My screen won't even go to sleep, let alone the whole computer though. It just gets stuck on the screen saver. :(
     
  6. mikeyredk macrumors 65816

    Joined:
    Mar 13, 2003
  7. tech4all macrumors 68040

    tech4all

    Joined:
    Jun 13, 2004
    Location:
    NorCal
    #7
    Thanks, Makosuke, for the info. I just did a test on my G5 and had the computer to sleep after 1 minute (same as display). However only the display went to sleep but the computer just kept running. Do you have to wait an extra minute after the displays goes to sleep for the compute to go to sleep?

    Running 10.4.2. Not sure if it's the same problem, but it sounds similar.
     
  8. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #8
    Ordinarily, no, and this is the same way I've been testing it. I've also waited the extra minute (also ten) to make sure, and it doesn't help.
     
  9. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #9
    Partly Figured Out Sleep Issue

    Ok, after an hour of experimentation, I have at least some leads on what the issue I've been having is; this might help others (or perhaps someone can offer additional suggestions), so here goes:

    * First of all, the time to auto-sleep is the cumulative time of the monitor and system sleep sliders in Energy Saver. I'm fairly certain it's not supposed to work this way (and it didn't used to), but it does now (plus about 20 seconds, in fact). Perhaps it's reading the monitor going to sleep as activity, and so resetting the sleep timer.

    * Second, having the put hard drives to sleep checkbox checked seems to screw with the timing; for example, with the sliders set to 1 and 2 minutes, respectively, it should've take 3:20 to sleep, but ended up taking a bit over 5 minutes, and I could hear the drives power up and down a couple of times during that. This seems to be irregular, though.

    * Third, the big culprit appears to be BitTorrent; after even just briefly launching Azureus (by the way, the "extra" app that doesn't quit properly seems to have disappeared under 10.4.3, so that's not a cause) I noticed that there were connection attempts hammering at the port I left open for it. Turn off the modem, normal sleep. Close that port, also normal sleep.

    Apparently, anyway, OSX reads connection attempts to an open port, even if unanswered, as reason enough not to sleep. This isn't necessarily wrong behavior, but I do believe it's different from the past.

    So, although this might not solve the problem for others, my tip would be: When you're done with your BitTorrent client, re-close the firewall port you left open for it. This, apparently, will allow normal sleep. Otherwise, if I've identified this issue correctly, you'll have to wait until the connection attempts peter out or your DSL modem drops the connection from inactivity (if it even will) for your Mac to sleep.

    I'll keep messing with this and see if I figure out anything else.
     
  10. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #10
    Thanks for that Makosuke. :)

    I don't use any torrent apps but I find iTunes to be a pretty big non-sleep instigator in 10.4.3. I haven't had a chance to thoroughly test it, but it seems to extend my auto sleep time by a few minutes. It's really interesting what you're saying about the hard drive too. :)
     
  11. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #11
    I'd like to hear what other folks find the actual TTS (time to sleep... you can credit me with that) is with hard drives set to sleep compared with not.

    Definitely made a difference in my case, but it might also have something to do with my having two internal drives. Wonder if it works properly with a single drive...?

    Also, can anybody confirm the monitor+system sleep time? It unquestionably does that on my system, but I'm wondering if it's isolated, and if not when this started happening--I'm fairly certain 10.3, at least, didn't behave that way.
     
  12. vamp07 macrumors member

    Joined:
    Nov 22, 2005
    #12
    I spent too much time today trying to figure out why my new imac g5 20" would not sleep. I set sleep to 1 minute. If sleep is working correctly it should star blinking the power light after one minute.

    The steps I followed:

    I figured out that if nobody was logged in it would go to sleep just fine. This should raise a flag that you have some app preventing sleep.

    A new user I created would not go to sleep so the problem was not specific to my account.

    Disconnecting all usb devices made no difference.

    Turning off the wireless network made no difference.

    I ended up bringing up Activity monitor and killing "My processes" one at a time and waiting one minute to see if the machine would go to sleep. Turns out that in my case the culprit was "HP Scanjet Monitor" An app that the hp scanning software installs to intercept button presses on the scanner. Getting this app to not autotart was another adventure. It installs itself into the "loginwindows.plist" which lives in the /library/preferences". This file is the same as the one that every user has and is controlled through user system preferences - login items. That one lived under you personal library ~/library. This other one is system wide and it is where the hp software installs itself. Hopeful this bit of info will help the next person with this sort of problem. By the way editing that plist file under tiger requires special software. I ended up downloading "PlistEdit Pro". I tried opening it in a text editor as several posts suggested but the format of those files changed with 10.4 and they are now some form of DB and should not be messed with in a text editor.

    Steve
     
  13. Makosuke thread starter macrumors 603

    Joined:
    Aug 15, 2001
    Location:
    The Cool Part of CA, USA
    #13
    Good catch, vamp07--that HP app is known for causing all manner of issues.

    My issue seems to be improved after I started closing the port when I wasn't using it, but that hasn't completely cleared up the issue--there are still times it fails to auto-sleep for no apparent reason.

    I'd thought it might be the button manager app for my Canon scanner, but killing that (or any of the other background apps I've installed) didn't end up helping in my case.
     
  14. vamp07 macrumors member

    Joined:
    Nov 22, 2005
    #14
    Does it sleep ok when nobody is logged in?



     
  15. thomasfromiowa macrumors newbie

    Joined:
    Aug 7, 2011
    #15
    I fixed it!! 2003 Dual 2 ghz Powerbook G5

    I could never figure out why my trusty G5 wouldn't go to sleep. I tried so many options listed here and in other forums.

    The problem: My PCI-X AlchemyTV G4/G5 slot card from Miglia. I am not sure when it started, but perhaps on the upgrade to Leopard. I had reformatted my hard drive and started again, but still had the problems.

    The fix? I downloaded the latest sofware version from Miglia and installed it onto my computer and it fixed the problem on restart!!! YEAH!!

    Perhaps those of you with a Miglia PCI-X AlchemyTV card are having that problem or perhaps another PCI-X card is the issue! Make sure you have the latest software version, firmware upgrade, etc.

    Good luck!!!
     
  16. thomasfromiowa macrumors newbie

    Joined:
    Aug 7, 2011
    #16
    Download link for up-to-date Miglia, AlchemyTV software

    Here is where I downloaded the updated software for my Miglia PCI-X AlchemyTV card.

    http://www.macupdate.com/app/mac/14160/alchemytv-dvr

    By the way. I am using OS X 10.5.8 on my Dual 2 Ghz PowerPC G5 (original 2003 cheesgrater Powermac) - yeah - the one with the fans that won't stop roaring. (any one have a fix for that?!!)
     

Share This Page